summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-08-24 20:10:14 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-08-24 20:41:12 +0200
commit1a6c51542e58e112e6920f12c0a88f2d46720723 (patch)
tree73995cedfa35a83554b3ec5ca14f436c818fd795 /dev-python
parentdev-python/debugpy: import from ::guru, new dep of ipykernel (diff)
downloadgentoo-1a6c51542e58e112e6920f12c0a88f2d46720723.tar.gz
gentoo-1a6c51542e58e112e6920f12c0a88f2d46720723.tar.bz2
gentoo-1a6c51542e58e112e6920f12c0a88f2d46720723.zip
dev-python/ipykernel: add version 6.2.0
new dep debugpy needs keywording on arm arm64 ppc ppc64 riscv sparc x86 Closes: https://bugs.gentoo.org/809589 Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/ipykernel/Manifest1
-rw-r--r--dev-python/ipykernel/ipykernel-6.2.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/ipykernel/Manifest b/dev-python/ipykernel/Manifest
index bc0d83b6e71a..e9c2c4ae13c5 100644
--- a/dev-python/ipykernel/Manifest
+++ b/dev-python/ipykernel/Manifest
@@ -1 +1,2 @@
DIST ipykernel-5.5.4.tar.gz 112728 BLAKE2B 489e12d0cbde2f80f2c921f026c7b84554b1fef481164e07f89b063127b01d106fc6b19f830ac321d79285fb9df065352dbc0c2a997b3629a64e766d2e50f347 SHA512 96728321fe71d528435415eda917c623269af734598a78168144d983aa64db4f9ced981fa67c83263da1ed878831669d821b84a769a08a271adafacfcbb75bf9
+DIST ipykernel-6.2.0.tar.gz 110042 BLAKE2B e1e9f140d434142339c36cdf72c9c4224143aeac8ee5938488fefaf0c15b33ddb6a4e4f49e4096431c89ba6bdcf6321f73e61927186d42518cd73e6016a017ed SHA512 7f3203b072cf7a4ca71e56df0c5621f6ac44440ace2ba855b7354971d04e872621650a0351f9d1ace50ea63459290835306e71fb91d414355810fa79968ddf56
diff --git a/dev-python/ipykernel/ipykernel-6.2.0.ebuild b/dev-python/ipykernel/ipykernel-6.2.0.ebuild
new file mode 100644
index 000000000000..489193326312
--- /dev/null
+++ b/dev-python/ipykernel/ipykernel-6.2.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="threads(+)"
+inherit distutils-r1
+
+DESCRIPTION="IPython Kernel for Jupyter"
+HOMEPAGE="https://github.com/ipython/ipykernel"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/debugpy-1.0.0[${PYTHON_USEDEP}]
+ <dev-python/debugpy-2.0[${PYTHON_USEDEP}]
+ >=dev-python/ipython-7.23.1[${PYTHON_USEDEP}]
+ <dev-python/ipython-8.0[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-4.1.0[${PYTHON_USEDEP}]
+ <dev-python/traitlets-6.0[${PYTHON_USEDEP}]
+ <dev-python/jupyter_client-8.0[${PYTHON_USEDEP}]
+ >=www-servers/tornado-4.2[${PYTHON_USEDEP}]
+ <www-servers/tornado-7.0[${PYTHON_USEDEP}]
+ >=dev-python/matplotlib-inline-0.1.0[${PYTHON_USEDEP}]
+ <dev-python/matplotlib-inline-0.2.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/nose_warnings_filters[${PYTHON_USEDEP}]
+ dev-python/ipyparallel[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest