summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-09-30 11:00:55 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-09-30 11:22:47 +0300
commit08d5d254bb20db1653396d1b7854cbf565193476 (patch)
tree0de8abe39e2aa9fcbc96ccff423e267d96670553 /dev-python
parentdev-python/nuitka: drop 1.0.6, 1.0.7 (diff)
downloadgentoo-08d5d254bb20db1653396d1b7854cbf565193476.tar.gz
gentoo-08d5d254bb20db1653396d1b7854cbf565193476.tar.bz2
gentoo-08d5d254bb20db1653396d1b7854cbf565193476.zip
dev-python/cfn-lint: add 0.66.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/cfn-lint/Manifest1
-rw-r--r--dev-python/cfn-lint/cfn-lint-0.66.0.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/cfn-lint/Manifest b/dev-python/cfn-lint/Manifest
index f14d4a7e5de6..6b50d842dc63 100644
--- a/dev-python/cfn-lint/Manifest
+++ b/dev-python/cfn-lint/Manifest
@@ -3,3 +3,4 @@ DIST cfn-lint-0.63.2.gh.tar.gz 9672817 BLAKE2B dcd445c2372bf044bc4eab4b33056d211
DIST cfn-lint-0.64.1.gh.tar.gz 9792758 BLAKE2B 95bc86fa41c17498575abfd4eb7e16d9e8a8dfc36d4304aa216890773e52d1e43f4deb178f2bd69c8edc445a417ca37ef53069ac9d398ccf27e3b9a6d90ee8c9 SHA512 edd7296e74db943c6ae818c2ae8f5220c4d8834eb7858c474e38f7852c1a7839b89ba949c105a3d2044f4b952e56fdc9e7a08493ed74e06b29ec9c0ea0b48a6a
DIST cfn-lint-0.65.0.gh.tar.gz 9807118 BLAKE2B abafc4fac788ba0af80359997b92cd60089472dee51952fc3029485a87be8e8fb9deb1599610471216ee8da103f7198808f9122727182005140c527672a921f8 SHA512 68eeb18914fb92cdacea9f80d4564937eba92b645f62a3fc22e874001554837ac3107741d4134cc8b1d880eaca38a560a92631c6ae3dfb2c412ad6fcb3f91cab
DIST cfn-lint-0.65.1.gh.tar.gz 9670213 BLAKE2B 22a627dc417f8df76fef9228eb4139210f693b0f5723e70f0dcb3651a18c921e8f174b8c97709016b2c184f3e12e03e49ad7e7a720415ad5cb820aecdfba4616 SHA512 391db28d47caa5cb66f3994944766f9ba6a0500ac5c8c474cef0a60e44236aedde7bceefb78cbc48cef3109ddf9206960a212df3ebdf7eb82b84940ca7202b7c
+DIST cfn-lint-0.66.0.gh.tar.gz 9710208 BLAKE2B e4d333d9ac0e05b9b6a7030ca63f2feb019d0b18d271f5e3d6a6176ac3c3c99c207709447be4397aecd831933f3938249786f6b043131b584432c04bcc2c1304 SHA512 05580c6602becd1b2545c1a87ffdbd3abf21026f76de2c476c986da3972a4dbb2a4ecc31f53dc23732bcfdd52a9c7ceb620f88c12a0b4b22536b6cb692e55f06
diff --git a/dev-python/cfn-lint/cfn-lint-0.66.0.ebuild b/dev-python/cfn-lint/cfn-lint-0.66.0.ebuild
new file mode 100644
index 000000000000..d9b9960e1574
--- /dev/null
+++ b/dev-python/cfn-lint/cfn-lint-0.66.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="CloudFormation Linter"
+HOMEPAGE="
+ https://github.com/aws-cloudformation/cfn-lint/
+ https://pypi.org/project/cfn-lint/
+"
+SRC_URI="
+ https://github.com/aws-cloudformation/cfn-lint/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/aws-sam-translator-1.51.0[${PYTHON_USEDEP}]
+ dev-python/jsonpatch[${PYTHON_USEDEP}]
+ >=dev-python/jschema_to_python-1.2.3[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]
+ dev-python/junit-xml[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ >dev-python/pyyaml-5.4[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.15.0[${PYTHON_USEDEP}]
+ >=dev-python/sarif_om-1.0.4[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # TODO
+ test/unit/module/test_template.py::TestTemplate::test_build_graph
+ # requires git repo
+ test/unit/module/maintenance/test_update_documentation.py::TestUpdateDocumentation::test_update_docs
+ # Internet
+ test/unit/module/formatters/test_formatters.py::TestFormatters::test_sarif_formatter
+ test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_2
+ test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_3
+)
+
+src_prepare() {
+ # unpin the deps
+ sed -e 's:~=[0-9.]*::' -i setup.py || die
+ distutils-r1_src_prepare
+}