summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-29 09:23:11 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-29 10:16:17 +0200
commitee7c6f800a9231919959a730443d587fc86e3b44 (patch)
tree55ce3ff04474eeb81f58f1358b2b6071c52bf6ba /dev-python/zipp
parentkde-frameworks/knewstuff: Drop 5.86.0 (r0) (diff)
downloadgentoo-ee7c6f800a9231919959a730443d587fc86e3b44.tar.gz
gentoo-ee7c6f800a9231919959a730443d587fc86e3b44.tar.bz2
gentoo-ee7c6f800a9231919959a730443d587fc86e3b44.zip
dev-python/zipp: Bump to 3.5.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/zipp')
-rw-r--r--dev-python/zipp/Manifest1
-rw-r--r--dev-python/zipp/zipp-3.5.1.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/zipp/Manifest b/dev-python/zipp/Manifest
index 1d0a4877f374..c72c5f34bc5e 100644
--- a/dev-python/zipp/Manifest
+++ b/dev-python/zipp/Manifest
@@ -1 +1,2 @@
DIST zipp-3.5.0.tar.gz 13270 BLAKE2B ba3b6f82ed0f1a902050ee8a89b6876a839d180dc048dd19cd31ddbaf89ec0494b9444f2ac082ed347e3183ccaf2e8342748737c2a29e1a2bbc492a0bc34767c SHA512 676d7e9a7fde386b57a213975121aba015461453f0809a97d39d030b06918a4c54ba1cad21877ddf007560941ae285883098d81d5e6f17eb4636379345b4513d
+DIST zipp-3.5.1.tar.gz 13005 BLAKE2B fe50ce8467dcb62a3685a56d3feab0b227832320f4d97ba7eb12a07a66065c1acee8ecb391812e2c772e7c55bbd4966743891f9fd80adf1138b289ed0bc06cd6 SHA512 7043d491a7f5588416973c4ea9d1fb5e47ee7febe423d01ee131662867ed1d616e2df4d2c87ad327ff1b8b297a8b10c6584cfce5de27d09a81d7a7ce4fcc4815
diff --git a/dev-python/zipp/zipp-3.5.1.ebuild b/dev-python/zipp/zipp-3.5.1.ebuild
new file mode 100644
index 000000000000..bef59282ca20
--- /dev/null
+++ b/dev-python/zipp/zipp-3.5.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Backport of pathlib-compatible object wrapper for zip files"
+HOMEPAGE="https://github.com/jaraco/zipp"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+BDEPEND="
+ dev-python/toml[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-3.4.2[${PYTHON_USEDEP}]
+ test? ( dev-python/jaraco-itertools[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_sphinx docs \
+ ">=dev-python/jaraco-packaging-3.2" \
+ ">=dev-python/rst-linker-1.9"
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # speed tests are flaky by design
+ test_zipp.py::TestPath::test_implied_dirs_performance
+)
+
+EPYTEST_IGNORE=(
+ # Ignoring zipp.py from ${S} avoids ImportPathMismatchError with Python < 3.8
+ # by ensuring only zipp from ${BUILD_DIR} is loaded
+ zipp.py
+)
+
+python_prepare_all() {
+ # dep of disabled test
+ sed -i -e '/func_timeout/d' test_zipp.py || die
+ distutils-r1_python_prepare_all
+}