summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-18 17:19:01 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-18 17:56:12 +0200
commitec77e0931c46f95e5bcc4a94f81c8d887ee3ffa8 (patch)
tree456e32b5b120c799971fee451f858b17cf6cad22 /dev-python/zconfig
parentdev-python/zope-deprecation: Enable py3.13 (diff)
downloadgentoo-ec77e0931c46f95e5bcc4a94f81c8d887ee3ffa8.tar.gz
gentoo-ec77e0931c46f95e5bcc4a94f81c8d887ee3ffa8.tar.bz2
gentoo-ec77e0931c46f95e5bcc4a94f81c8d887ee3ffa8.zip
dev-python/zconfig: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/zconfig')
-rw-r--r--dev-python/zconfig/Manifest1
-rw-r--r--dev-python/zconfig/files/zconfig-4.0-py312.patch37
-rw-r--r--dev-python/zconfig/zconfig-4.0.ebuild45
3 files changed, 0 insertions, 83 deletions
diff --git a/dev-python/zconfig/Manifest b/dev-python/zconfig/Manifest
index 09edd9cb4c82..2555384ea9fe 100644
--- a/dev-python/zconfig/Manifest
+++ b/dev-python/zconfig/Manifest
@@ -1,2 +1 @@
-DIST ZConfig-4.0.tar.gz 126072 BLAKE2B 7057151267f9b481d3cded72a22dc8fe505f1eac78d156595eb6ba5ff6217b57713ae2ef307358d86320986181bbbb3c1862901297e645bf69dc4893a3e60dbc SHA512 03e3c34f8af9de8bedd98bbdf0c968fdd2fb0c1bb8d62a73c286b804a8841e0e7d9b647f5f3bb37a6d52dc2a5cea7cdce21cd204536399d43203c18e0c204ca7
DIST zconfig-4.1.tar.gz 146996 BLAKE2B fd4299121b418ba7517ef17c2f9be9e0f0a975199a0fb59bd45f54338becb921c2bf0fd87344e08b21734b80dc11abd64d7bef27d7d17313197d9c781b5e5017 SHA512 71dd5a9ce5f72eda76fde19fa2bec4aaf542ebe4b617753b14c07239366d934d9d635aa63407c76bc00edfb305c85c1cecdd187ee7f2b85f25acaa7682839363
diff --git a/dev-python/zconfig/files/zconfig-4.0-py312.patch b/dev-python/zconfig/files/zconfig-4.0-py312.patch
deleted file mode 100644
index 6f8c53ed18a0..000000000000
--- a/dev-python/zconfig/files/zconfig-4.0-py312.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-From 390ce89cfd4bf1a60d8d67ee20106288cbfa0e51 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Petr=20Van=C4=9Bk?= <arkamar@atlas.cz>
-Date: Fri, 23 Jun 2023 08:10:09 +0200
-Subject: [PATCH] Fix tests for Python 3.12 (#91)
-
-In the tests, remove the assertRaisesRegexp method, deprecated since
-Python 3.2, to prevent test failures following the method's removal in
-Python 3.12.
----
- src/ZConfig/tests/support.py | 7 -------
- 1 file changed, 7 deletions(-)
-
-diff --git a/src/ZConfig/tests/support.py b/src/ZConfig/tests/support.py
-index 959f2b9..559c015 100644
---- a/src/ZConfig/tests/support.py
-+++ b/src/ZConfig/tests/support.py
-@@ -17,7 +17,6 @@
- import contextlib
- import os
- import sys
--import unittest
- from io import StringIO
- from urllib.request import pathname2url
-
-@@ -79,12 +78,6 @@ def f2(self):
- class TestHelper:
- """Utility methods which can be used with the schema support."""
-
-- # Not derived from unittest.TestCase; some test runners seem to
-- # think that means this class contains tests.
--
-- assertRaisesRegex = getattr(unittest.TestCase, 'assertRaisesRegex',
-- unittest.TestCase.assertRaisesRegexp)
--
- def load_both(self, schema_url, conf_url):
- schema = self.load_schema(schema_url)
- conf = self.load_config(schema, conf_url)
diff --git a/dev-python/zconfig/zconfig-4.0.ebuild b/dev-python/zconfig/zconfig-4.0.ebuild
deleted file mode 100644
index e33522f6853f..000000000000
--- a/dev-python/zconfig/zconfig-4.0.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYPI_PN="ZConfig"
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Configuration library supporting a hierarchical schema-driven model"
-HOMEPAGE="
- https://github.com/zopefoundation/ZConfig/
- https://pypi.org/project/ZConfig/
-"
-
-LICENSE="ZPL"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64"
-
-BDEPEND="
- test? (
- dev-python/docutils[${PYTHON_USEDEP}]
- dev-python/manuel[${PYTHON_USEDEP}]
- dev-python/zope-exceptions[${PYTHON_USEDEP}]
- dev-python/zope-interface[${PYTHON_USEDEP}]
- )
-"
-
-DOCS=( CHANGES.rst README.rst )
-
-distutils_enable_tests unittest
-distutils_enable_sphinx docs \
- dev-python/sphinxcontrib-programoutput
-
-PATCHES=(
- # https://github.com/zopefoundation/ZConfig/commit/390ce89cfd4bf1a60d8d67ee20106288cbfa0e51
- "${FILESDIR}/${P}-py312.patch"
-)
-
-python_test() {
- eunittest -s src/ZConfig/tests
-}