summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-01-01 20:28:31 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-01-01 21:29:37 +0100
commitd45c9a391ffabb1192a298d7d1eb05e2debecf30 (patch)
tree28187b3853cbfaa9123e51db72eac64eac1ed95b /dev-python/ytmusicapi
parentdev-dotnet/netcoredbg: rmove nuget.config files with find (diff)
downloadgentoo-d45c9a391ffabb1192a298d7d1eb05e2debecf30.tar.gz
gentoo-d45c9a391ffabb1192a298d7d1eb05e2debecf30.tar.bz2
gentoo-d45c9a391ffabb1192a298d7d1eb05e2debecf30.zip
dev-python/ytmusicapi: bump to 1.4.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-python/ytmusicapi')
-rw-r--r--dev-python/ytmusicapi/Manifest1
-rw-r--r--dev-python/ytmusicapi/ytmusicapi-1.4.0.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/ytmusicapi/Manifest b/dev-python/ytmusicapi/Manifest
index 50d12a4b1673..430ce180711a 100644
--- a/dev-python/ytmusicapi/Manifest
+++ b/dev-python/ytmusicapi/Manifest
@@ -1 +1,2 @@
DIST ytmusicapi-1.3.2.tar.gz 71732 BLAKE2B 957c2b88ea2c9e59c81401762e4dfd4a52a2f5d3ba59653d2556c3d29225ab4bd92155070e75812f302430b453a5c32a2f44fb508b24905a8f0d16c6fe51299b SHA512 c9ccf7999d668502549e4b5393682192d1db2851660444b6255d5bfb2c0c994ab4715800b669bf57d60866aef7c5529ece374c1eda8d945c7008477438dd0fdd
+DIST ytmusicapi-1.4.0.tar.gz 94975 BLAKE2B c83170695e6f248d88cfa394c114f3931e98dfffa7770551c521163530c04ae56ed988ae4b06e124f788758274be8eb909e833a2b9bd3d282b6e16563829d44e SHA512 d3c73ae4171c20aab7982e377e0b949e7428010e41c7ac76ed0a7727c2e66fd8f814bb8914e4c016c76e8c72a2e08db2e3be736b298926e5fe3365288db95e09
diff --git a/dev-python/ytmusicapi/ytmusicapi-1.4.0.ebuild b/dev-python/ytmusicapi/ytmusicapi-1.4.0.ebuild
new file mode 100644
index 000000000000..52eef4b410a8
--- /dev/null
+++ b/dev-python/ytmusicapi/ytmusicapi-1.4.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Unofficial API for YouTube Music"
+HOMEPAGE="https://ytmusicapi.readthedocs.io/
+ https://github.com/sigma67/ytmusicapi/"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+
+RDEPEND="dev-python/requests[${PYTHON_USEDEP}]"
+
+distutils_enable_sphinx docs/source \
+ dev-python/sphinx-rtd-theme