summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-24 15:01:03 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-24 16:31:35 +0200
commite8633897e16ba09b8f5fe9b1fe1e481f8eceacae (patch)
tree4875e4a6257a39b67dd6db5e76a198a659fea6ce /dev-python/xcffib
parentdev-python/virtualenv: Bump to 20.0.28 (diff)
downloadgentoo-e8633897e16ba09b8f5fe9b1fe1e481f8eceacae.tar.gz
gentoo-e8633897e16ba09b8f5fe9b1fe1e481f8eceacae.tar.bz2
gentoo-e8633897e16ba09b8f5fe9b1fe1e481f8eceacae.zip
dev-python/xcffib: Bump to 0.10.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/xcffib')
-rw-r--r--dev-python/xcffib/Manifest1
-rw-r--r--dev-python/xcffib/xcffib-0.10.1.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/xcffib/Manifest b/dev-python/xcffib/Manifest
index 1f7a9aa59aa7..9ab96bdc9b09 100644
--- a/dev-python/xcffib/Manifest
+++ b/dev-python/xcffib/Manifest
@@ -1,2 +1,3 @@
DIST xcffib-0.10.0.tar.gz 84641 BLAKE2B 06f0ccd420437e11e1aff8d6c7111185d9ff8ed08e40ccab13fed2431134671c55722e0a7a72773cde8518a6c3d4ef14de1a99f0c61d85e9a8feff41545c626a SHA512 2d0a6e7c6b8b43e82f1621a8408ba951e67239099bc947a6da62a6735ff6584ba422e55659969093d51f6de53fe4a400b330def1e6b9eb2c698d82ffc9ff81e4
+DIST xcffib-0.10.1.tar.gz 84689 BLAKE2B e36ad4f9c6bf5bc63400ae35d0d58ea1def00f299c0f811807cde430e6a6850132e77584359f77fb2f4ce5fdf5f22ec91ed22e1b7ce5d6d318b7a8dc5f3e0939 SHA512 98412fe36962108902dc0599f05ac9be5d7412d7f12fc6566e020c2ce84ae4a536a20ae2dfddd2dc9a536f37cd82539bf19e1993ee65f0b09c44372008cd7edf
DIST xcffib-0.9.0.tar.gz 83063 BLAKE2B 898fbce1ff503a9ad64a4c34778e0b5ffef531cf2ad04327f1890c87adb5f91287465e39a981a3c5a628c048b8acbb38bac3b0b76a58c3bbe45ab34c9a5eacf5 SHA512 e5891f080fcf1df596c37bb64a70e0de4a41d83b4675dac3b1c128656ab1b09d865e3ab0bfe0e5cc523e89a75dc6127dfc455ab66ca543ba6eeae9ee5bdae168
diff --git a/dev-python/xcffib/xcffib-0.10.1.ebuild b/dev-python/xcffib/xcffib-0.10.1.ebuild
new file mode 100644
index 000000000000..790a52834b15
--- /dev/null
+++ b/dev-python/xcffib/xcffib-0.10.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A drop in replacement for xpyb, an XCB python binding"
+HOMEPAGE="https://github.com/tych0/xcffib"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+DEPEND="x11-libs/libxcb"
+RDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/cffi-1.1:=[${PYTHON_USEDEP}]
+ ' 'python*')
+ dev-python/six[${PYTHON_USEDEP}]
+ ${DEPEND}"
+BDEPEND="
+ test? (
+ x11-base/xorg-server[xvfb]
+ x11-apps/xeyes
+ )"
+
+distutils_enable_tests nose