summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-18 08:03:35 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-18 08:03:35 +0200
commitb7bab460baf2ad0c6d283713741962d535725c37 (patch)
treeccb7ea3e943db6bc5d15f286a5e92d3bc5df3b16 /dev-python/xarray
parentdev-libs/libgit2: Bump to 1.7.0 (diff)
downloadgentoo-b7bab460baf2ad0c6d283713741962d535725c37.tar.gz
gentoo-b7bab460baf2ad0c6d283713741962d535725c37.tar.bz2
gentoo-b7bab460baf2ad0c6d283713741962d535725c37.zip
dev-python/xarray: Bump to 2023.7.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/xarray')
-rw-r--r--dev-python/xarray/Manifest1
-rw-r--r--dev-python/xarray/xarray-2023.7.0.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/xarray/Manifest b/dev-python/xarray/Manifest
index 6512b8974a11..18dd39b61cfa 100644
--- a/dev-python/xarray/Manifest
+++ b/dev-python/xarray/Manifest
@@ -1,2 +1,3 @@
DIST xarray-2023.5.0.tar.gz 3707468 BLAKE2B 55ee416c41aff8edcb609adcac1c0a2e1d4ae896c25ae3d771d755930725f69f854feac42c42558db598acc5d0a852370198908d85d5af9664c485052948f4ca SHA512 ab6538b280f05acc296d8d73003e07f494d330a2a6a486d2f3dac121aee9682e2fa46c05be868b23a31584c908e0f6454757bdac7ec032d3a6f79a4500c0629f
DIST xarray-2023.6.0.tar.gz 3711562 BLAKE2B 3b6b20cf0046aaeeafe87980c6c107486d79afd2881c4f98b42c17025f0d448763d37b5d5fd71cf17fcfcfbdc2d3337e985c7517038547300f4cf57ffe1aea98 SHA512 2b1b48bd90935a3b56f5f017085d40cc10081efbe0a84c908d1203066f29b4bf16fc89e771d961f26009bb20a84a59f4b9d99e42b5e25b2bbd8eca55a80839d6
+DIST xarray-2023.7.0.tar.gz 3725483 BLAKE2B 814af19a4c24eb0179441d07bcd6165dee2ed5430a6fd94f4014387b7b7fd4ae250b64124bdda8ca411124ab2276075af65bde2a3ed3dc6d081dd466a485007e SHA512 88863770b22978ba681a2d970453ae087a234fcfb68f047b6020b39841a91207e8d92e01486d58bbeadac8d14608aa0c744ee9b6d54890f52fe3537b28292239
diff --git a/dev-python/xarray/xarray-2023.7.0.ebuild b/dev-python/xarray/xarray-2023.7.0.ebuild
new file mode 100644
index 000000000000..6672e7602e28
--- /dev/null
+++ b/dev-python/xarray/xarray-2023.7.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 multiprocessing pypi
+
+DESCRIPTION="N-D labeled arrays and datasets in Python"
+HOMEPAGE="
+ https://xarray.pydata.org/
+ https://github.com/pydata/xarray/
+ https://pypi.org/project/xarray/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/numpy-1.22[${PYTHON_USEDEP}]
+ >=dev-python/pandas-1.4[${PYTHON_USEDEP}]
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+"
+# note: most of the test dependencies are optional
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/bottleneck[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/toolz[${PYTHON_USEDEP}]
+ !hppa? ( >=dev-python/scipy-1.4[${PYTHON_USEDEP}] )
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # warning-targeted tests are fragile and not important to end users
+ xarray/tests/test_backends.py::test_no_warning_from_dask_effective_get
+ # TODO: segv in netcdf4-python
+ 'xarray/tests/test_backends.py::test_open_mfdataset_manyfiles[netcdf4-20-True-5-5]'
+ 'xarray/tests/test_backends.py::test_open_mfdataset_manyfiles[netcdf4-20-True-5-None]'
+ 'xarray/tests/test_backends.py::test_open_mfdataset_manyfiles[netcdf4-20-True-None-5]'
+ 'xarray/tests/test_backends.py::test_open_mfdataset_manyfiles[netcdf4-20-True-None-None]'
+ xarray/tests/test_backends.py::TestDask::test_save_mfdataset_compute_false_roundtrip
+ # hangs
+ xarray/tests/test_backends.py::TestDask::test_dask_roundtrip
+)
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p xdist.plugin -n "$(makeopts_jobs)" --dist=worksteal
+}