summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2017-08-19 22:36:30 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2017-08-19 22:36:30 +0000
commit6c78b3eb182dd656e53c8762e9e0feacea08eaba (patch)
treefd09b82a03122d4eb9c3138e64752d65058e1f37 /dev-python/widgetsnbextension/widgetsnbextension-3.0.0.ebuild
parentdev-python/ipython: unset smp as default to ease circular deps on ipyparallel (diff)
downloadgentoo-6c78b3eb182dd656e53c8762e9e0feacea08eaba.tar.gz
gentoo-6c78b3eb182dd656e53c8762e9e0feacea08eaba.tar.bz2
gentoo-6c78b3eb182dd656e53c8762e9e0feacea08eaba.zip
dev-python/widgetsnbextension: version bump
Package-Manager: Portage-2.3.7, Repoman-2.3.3
Diffstat (limited to 'dev-python/widgetsnbextension/widgetsnbextension-3.0.0.ebuild')
-rw-r--r--dev-python/widgetsnbextension/widgetsnbextension-3.0.0.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/widgetsnbextension/widgetsnbextension-3.0.0.ebuild b/dev-python/widgetsnbextension/widgetsnbextension-3.0.0.ebuild
new file mode 100644
index 000000000000..0f0c8010c0f1
--- /dev/null
+++ b/dev-python/widgetsnbextension/widgetsnbextension-3.0.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="IPython HTML widgets for Jupyter"
+HOMEPAGE="http://ipython.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=">=dev-python/notebook-4.4.1[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"