summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-07-12 20:52:33 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-07-12 20:57:35 +0200
commit96eca91361f165da916c4003b28dbd2e282066a8 (patch)
tree013b4c0b11d589e3d503fa4732cc7b3a3a853bc2 /dev-python/whatthepatch
parentapp-admin/sysstat: fix minor qa issues (diff)
downloadgentoo-96eca91361f165da916c4003b28dbd2e282066a8.tar.gz
gentoo-96eca91361f165da916c4003b28dbd2e282066a8.tar.bz2
gentoo-96eca91361f165da916c4003b28dbd2e282066a8.zip
dev-python/whatthepatch: new package, add 1.0.2
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/whatthepatch')
-rw-r--r--dev-python/whatthepatch/Manifest1
-rw-r--r--dev-python/whatthepatch/metadata.xml13
-rw-r--r--dev-python/whatthepatch/whatthepatch-1.0.2.ebuild19
3 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/whatthepatch/Manifest b/dev-python/whatthepatch/Manifest
new file mode 100644
index 000000000000..39646ce779dc
--- /dev/null
+++ b/dev-python/whatthepatch/Manifest
@@ -0,0 +1 @@
+DIST whatthepatch-1.0.2.tar.gz 28459 BLAKE2B e24c882fe1ad42f27eeced72d92423d807ac3284bf0045674b78a247a7222bb142d500129b82a32f8fc95934beaa87a378822da2ef80b1d66d98c171b3a15666 SHA512 e77aa6e934f26647b7a060f46eedd8f5984e43b93b7d576cf8d7a930d08e4b3c5c96c79e61e001df405f3f18c07e4296ce79009d9b9e9c721342af9f8560b4cf
diff --git a/dev-python/whatthepatch/metadata.xml b/dev-python/whatthepatch/metadata.xml
new file mode 100644
index 000000000000..a52b8caec8c1
--- /dev/null
+++ b/dev-python/whatthepatch/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">whatthepatch</remote-id>
+ <remote-id type="github">cscorley/whatthepatch</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/whatthepatch/whatthepatch-1.0.2.ebuild b/dev-python/whatthepatch/whatthepatch-1.0.2.ebuild
new file mode 100644
index 000000000000..3df171e6eecf
--- /dev/null
+++ b/dev-python/whatthepatch/whatthepatch-1.0.2.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A patch parsing and application library."
+HOMEPAGE="https://github.com/cscorley/whatthepatch"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests pytest