summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-17 12:03:24 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-17 12:03:36 +0100
commit85da0e01da3fd569a6b291352297dfa9d018ab70 (patch)
tree7a7f86fc4219c213443700fd87deb680c68042e5 /dev-python/werkzeug/werkzeug-0.11.2.ebuild
parentdev-python/pyparsing: Version Bump (diff)
downloadgentoo-85da0e01da3fd569a6b291352297dfa9d018ab70.tar.gz
gentoo-85da0e01da3fd569a6b291352297dfa9d018ab70.tar.bz2
gentoo-85da0e01da3fd569a6b291352297dfa9d018ab70.zip
dev-python/werkzeug: Version Bump
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/werkzeug/werkzeug-0.11.2.ebuild')
-rw-r--r--dev-python/werkzeug/werkzeug-0.11.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/werkzeug/werkzeug-0.11.2.ebuild b/dev-python/werkzeug/werkzeug-0.11.2.ebuild
new file mode 100644
index 000000000000..c6dd78d7cbc9
--- /dev/null
+++ b/dev-python/werkzeug/werkzeug-0.11.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy )
+
+inherit distutils-r1
+
+MY_PN="Werkzeug"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Collection of various utilities for WSGI applications"
+HOMEPAGE="http://werkzeug.pocoo.org/ https://pypi.python.org/pypi/Werkzeug"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="test"
+
+RDEPEND="dev-python/simplejson[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-xprocess[${PYTHON_USEDEP}]
+ )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_test() {
+ esetup.py test
+}