summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-28 21:16:42 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-28 21:20:12 +0200
commit7ce402d788c379cc2110c6841902840b6686573b (patch)
treecf886924c5a74f52a69d26a9b717c6ebaa2c398e /dev-python/vcrpy/vcrpy-6.0.1.ebuild
parentsys-apps/flashrom-1.3.0-r2: fix libflashrom mapfile #928955 (diff)
downloadgentoo-7ce402d788c379cc2110c6841902840b6686573b.tar.gz
gentoo-7ce402d788c379cc2110c6841902840b6686573b.tar.bz2
gentoo-7ce402d788c379cc2110c6841902840b6686573b.zip
dev-python/vcrpy: Enable py3.13
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/vcrpy/vcrpy-6.0.1.ebuild')
-rw-r--r--dev-python/vcrpy/vcrpy-6.0.1.ebuild19
1 files changed, 18 insertions, 1 deletions
diff --git a/dev-python/vcrpy/vcrpy-6.0.1.ebuild b/dev-python/vcrpy/vcrpy-6.0.1.ebuild
index 257bac69d0b4..f65324722b8e 100644
--- a/dev-python/vcrpy/vcrpy-6.0.1.ebuild
+++ b/dev-python/vcrpy/vcrpy-6.0.1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( python3_{10..13} )
inherit distutils-r1
@@ -62,6 +62,23 @@ python_test() {
tests/integration/test_aiohttp.py
)
+ case ${EPYTHON} in
+ python3.13)
+ EPYTEST_DESELECT+=(
+ # SSL problems, might be weak bundle in pytest-httpbin
+ # https://github.com/kevin1024/vcrpy/issues/848
+ "tests/integration/test_urllib2.py::test_cross_scheme"
+ "tests/integration/test_urllib2.py::test_decorator[https]"
+ "tests/integration/test_urllib2.py::test_get_data[https]"
+ "tests/integration/test_urllib2.py::test_post_data[https]"
+ "tests/integration/test_urllib2.py::test_post_decorator[https]"
+ "tests/integration/test_urllib2.py::test_post_unicode_data[https]"
+ "tests/integration/test_urllib2.py::test_response_code[https]"
+ "tests/integration/test_urllib2.py::test_response_headers[https]"
+ )
+ ;;
+ esac
+
local -x REQUESTS_CA_BUNDLE=$("${EPYTHON}" -m pytest_httpbin.certs)
epytest -m 'not online'
}