summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-13 09:07:50 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-13 09:20:25 +0200
commit3688e3743242d77c8c5919532c5ebca359cabff5 (patch)
treea853e852ce611b837dfebad87803da15c4ed6bdc /dev-python/uritemplate
parentdev-python/wrapt: Bump to 1.13.2 (diff)
downloadgentoo-3688e3743242d77c8c5919532c5ebca359cabff5.tar.gz
gentoo-3688e3743242d77c8c5919532c5ebca359cabff5.tar.bz2
gentoo-3688e3743242d77c8c5919532c5ebca359cabff5.zip
dev-python/uritemplate: Bump to 4.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/uritemplate')
-rw-r--r--dev-python/uritemplate/Manifest1
-rw-r--r--dev-python/uritemplate/uritemplate-4.1.0.ebuild17
2 files changed, 18 insertions, 0 deletions
diff --git a/dev-python/uritemplate/Manifest b/dev-python/uritemplate/Manifest
index 7fab4aa01831..3706f8edf7a8 100644
--- a/dev-python/uritemplate/Manifest
+++ b/dev-python/uritemplate/Manifest
@@ -1,2 +1,3 @@
DIST uritemplate-3.0.1.tar.gz 32806 BLAKE2B 71fb7ef9fbdd61f3a3f67c5615cfb65ab261b5f9ce1c5a534e155a9723990599bf50e9ee0934d870161f7f26fc3d0fbcc07fefa558fc55bca29e96259bba767a SHA512 260da5901d28ca2354d972e00ed468c9bcf2901f948cb7759ff3e9d3a7b67da90ba754e555d6695c5095801b106ffd422459f0860b901a75e01575e159eb8f48
DIST uritemplate-4.0.0.tar.gz 31879 BLAKE2B b363864782240b6ccd7ecdb84142246d75800b7a173631c741d10a793817a32755d0ba35e529579663af3efd01c75e5838187f547757f9fbb38050e4af283193 SHA512 1428967387c7f157f0c512f044deccce93770fd50c6d1427393cddf835137588ba7c9253ac4a838866c0c3c128c5e96189a54d7a772210b740de50474afbc58a
+DIST uritemplate-4.1.0.tar.gz 273924 BLAKE2B b21115c6db8f94c635dda1033b4650dd7d2d54b6f52f51bff31ae8cf89e0b3dbcfc1bd029eadc68f5f94eecbd167eabc652c24be6f0bb807beecb5f254520626 SHA512 e62812a4e9ff315a1b06ba9e88f3dd47aea8353cae4ead9ce7bf59b65c83cd6ae7c973cb29b8ddc25266c264f229df8f2d9e982ab489f2f37a5dbd460b87a5e0
diff --git a/dev-python/uritemplate/uritemplate-4.1.0.ebuild b/dev-python/uritemplate/uritemplate-4.1.0.ebuild
new file mode 100644
index 000000000000..b9ff89a61c9a
--- /dev/null
+++ b/dev-python/uritemplate/uritemplate-4.1.0.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of RFC6570, URI Template"
+HOMEPAGE="https://pypi.org/project/uritemplate/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+distutils_enable_tests pytest