summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-18 17:50:53 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-18 17:53:11 +0200
commitb9d94fe63f88f393d310f12d6a3ee96ea16315b1 (patch)
tree43d871d8361cb6fc996cad43af0212c667e70f53 /dev-python/uranium
parentdev-python/ujson: Remove old (diff)
downloadgentoo-b9d94fe63f88f393d310f12d6a3ee96ea16315b1.tar.gz
gentoo-b9d94fe63f88f393d310f12d6a3ee96ea16315b1.tar.bz2
gentoo-b9d94fe63f88f393d310f12d6a3ee96ea16315b1.zip
dev-python/uranium: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/uranium')
-rw-r--r--dev-python/uranium/Manifest1
-rw-r--r--dev-python/uranium/uranium-4.6.1.ebuild76
2 files changed, 0 insertions, 77 deletions
diff --git a/dev-python/uranium/Manifest b/dev-python/uranium/Manifest
index 6e63bbf18ee6..058d436e4857 100644
--- a/dev-python/uranium/Manifest
+++ b/dev-python/uranium/Manifest
@@ -1,2 +1 @@
-DIST uranium-4.6.1.tar.gz 1013314 BLAKE2B 2a89eb1c4ffab35879eea9a681ea20e9cc5f78736d9c8bda5bf33baf5ef6d3f6418fd1f4b779738d644afd2d553d500c4892559ae402eeab0c38a4d95b295cf5 SHA512 ba7ed12d507fb1bd08fc0e77285933802a31b63d09f2dd0c7329e5644f82e6372fa11a1bbc28f3f1928ae0acfb3cb0afdeedf8e90e619c484fd5f623f8af722a
DIST uranium-4.7.0.tar.gz 1021541 BLAKE2B 2a2e354def88764801f275751aaf7643c9f4ca6329c2c302d87b3d617d0e93921d0aef20b0c25c9b0a082a836f7d0cca962dfedaa0298fcf943b1a0b683e0e28 SHA512 e049fff57823107785b418a368d6c6c399775c35ffad90831c77643dee060be2ab13ad8871b11f8d59d2a090a1d26786f4cf39a5a731b616a1b08a8ae5dea996
diff --git a/dev-python/uranium/uranium-4.6.1.ebuild b/dev-python/uranium/uranium-4.6.1.ebuild
deleted file mode 100644
index 19a97cf4fd23..000000000000
--- a/dev-python/uranium/uranium-4.6.1.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8} )
-
-inherit cmake python-single-r1
-
-MY_PN="Uranium"
-
-DESCRIPTION="A Python framework for building 3D printing related applications"
-HOMEPAGE="https://github.com/Ultimaker/Uranium"
-SRC_URI="https://github.com/Ultimaker/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="LGPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug doc test"
-RESTRICT="!test? ( test )"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-BDEPEND="${PYTHON_DEPS}
- sys-devel/gettext
- doc? ( app-doc/doxygen )
- test? (
- $(python_gen_cond_dep '
- dev-python/pytest[${PYTHON_MULTI_USEDEP}]
- dev-python/mypy[${PYTHON_MULTI_USEDEP}]
- ')
- )"
-
-DEPEND="${PYTHON_DEPS}
- ~dev-libs/libarcus-${PV}:=[python,${PYTHON_SINGLE_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/PyQt5[${PYTHON_MULTI_USEDEP},declarative,network,svg]
- dev-python/numpy[${PYTHON_MULTI_USEDEP}]
- >=dev-python/scipy-1.1[${PYTHON_MULTI_USEDEP}]
- sci-libs/Shapely[${PYTHON_MULTI_USEDEP}]
- ')"
-
-RDEPEND="${DEPEND}
- dev-qt/qtquickcontrols:5
- dev-qt/qtquickcontrols2:5"
-
-DOCS=( README.md )
-
-PATCHES=( "${FILESDIR}/${PN}-4.6.1-fix-install-paths.patch" )
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-src_configure() {
- local mycmakeargs=(
- -DPYTHON_SITE_PACKAGES_DIR="$(python_get_sitedir)"
- )
- cmake_src_configure
-
- if ! use debug; then
- sed -i 's/logging.DEBUG/logging.ERROR/' plugins/ConsoleLogger/ConsoleLogger.py || die
- sed -i 's/logging.DEBUG/logging.ERROR/' plugins/FileLogger/FileLogger.py || die
- fi
-}
-
-src_compile() {
- cmake_src_compile
- if use doc; then
- cmake_src_compile doc
- HTML_DOCS=( html )
- fi
-}
-
-src_install() {
- cmake_src_install
- python_optimize
- python_optimize "${D}/usr/$(get_libdir)"
-}