summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-10-30 16:44:53 +0800
committerIan Delaney <idella4@gentoo.org>2015-10-30 16:45:29 +0800
commit9a29fb9714827b52a55b1fd482ef9394158c5a97 (patch)
tree4f41ea1c91ffa53f94f2ff39f895e56d0a7b6011 /dev-python/unicodecsv/unicodecsv-0.14.1.ebuild
parentmedia-libs/libmatroska: amd64 stable wrt bug #564426 (diff)
downloadgentoo-9a29fb9714827b52a55b1fd482ef9394158c5a97.tar.gz
gentoo-9a29fb9714827b52a55b1fd482ef9394158c5a97.tar.bz2
gentoo-9a29fb9714827b52a55b1fd482ef9394158c5a97.zip
dev-python/unicodecsv: bump to -0.14.1, fixes gentoo bug
Add py3.5 support, unrestrict test phase, upgrade test phase, remove old, bump request by Andrew Wilcox, via the gentoo bug Gentoo bug: #564294 Package-Manager: portage-2.2.23
Diffstat (limited to 'dev-python/unicodecsv/unicodecsv-0.14.1.ebuild')
-rw-r--r--dev-python/unicodecsv/unicodecsv-0.14.1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/unicodecsv/unicodecsv-0.14.1.ebuild b/dev-python/unicodecsv/unicodecsv-0.14.1.ebuild
new file mode 100644
index 000000000000..788e74a7c3ec
--- /dev/null
+++ b/dev-python/unicodecsv/unicodecsv-0.14.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Drop-in replacement for python stdlib csv module supporting unicode"
+HOMEPAGE="https://pypi.python.org/pypi/unicodecsv https://github.com/jdunck/python-unicodecsv"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc"
+IUSE=""
+
+python_test() {
+ python -m unittest discover
+}