summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2023-09-03 18:27:36 -0400
committerMichał Górny <mgorny@gentoo.org>2023-10-10 22:47:17 +0200
commit95e2387bda8a176489273d195430cc91cbd1dd3a (patch)
tree2a6743a62d8d511fc9f5112b4760f620a61a8f36 /dev-python/types-psutil
parentdev-python/mypy: Deselect tests broken with assertions (diff)
downloadgentoo-95e2387bda8a176489273d195430cc91cbd1dd3a.tar.gz
gentoo-95e2387bda8a176489273d195430cc91cbd1dd3a.tar.bz2
gentoo-95e2387bda8a176489273d195430cc91cbd1dd3a.zip
dev-python/types-psutil: new package, add 5.9.5.16
Needed for mypy to build compiled extensions. Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/types-psutil')
-rw-r--r--dev-python/types-psutil/Manifest1
-rw-r--r--dev-python/types-psutil/metadata.xml13
-rw-r--r--dev-python/types-psutil/types-psutil-5.9.5.16.ebuild17
3 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/types-psutil/Manifest b/dev-python/types-psutil/Manifest
new file mode 100644
index 000000000000..2a480985a542
--- /dev/null
+++ b/dev-python/types-psutil/Manifest
@@ -0,0 +1 @@
+DIST types-psutil-5.9.5.16.tar.gz 14060 BLAKE2B 942e4c112568a864a0de79b40ddbe805dd3a10e445c4750b7feaa3cd8e8cf83198e8d472c603f6fbd00c4a0d3a4dc44741b03a3db5d039d8856b56cbe6321fc7 SHA512 e471ef3e03be57bfbcd551a6d0c1db353d2c8af140a3096453f30f069f546ca8943caf48369f7627919c8b9fd203dede7e7573a6e4ea5c65b0fe3f5f60175d3f
diff --git a/dev-python/types-psutil/metadata.xml b/dev-python/types-psutil/metadata.xml
new file mode 100644
index 000000000000..11bbf2400c0c
--- /dev/null
+++ b/dev-python/types-psutil/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">types-psutil</remote-id>
+ <remote-id type="github">python/typeshed</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/types-psutil/types-psutil-5.9.5.16.ebuild b/dev-python/types-psutil/types-psutil-5.9.5.16.ebuild
new file mode 100644
index 000000000000..2e5813b51c93
--- /dev/null
+++ b/dev-python/types-psutil/types-psutil-5.9.5.16.ebuild
@@ -0,0 +1,17 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Typing stubs for psutil"
+HOMEPAGE="https://pypi.org/project/types-psutil/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"