summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-13 04:45:35 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-13 05:12:13 +0200
commit842e7ecdde6de2b61384e9b88148703677aa901e (patch)
tree75f9fca6f4155b5f007b5dc60a8c4c48084ebf20 /dev-python/trove-classifiers
parentdev-python/stripe: Bump to 10.11.0 (diff)
downloadgentoo-842e7ecdde6de2b61384e9b88148703677aa901e.tar.gz
gentoo-842e7ecdde6de2b61384e9b88148703677aa901e.tar.bz2
gentoo-842e7ecdde6de2b61384e9b88148703677aa901e.zip
dev-python/trove-classifiers: Bump to 2024.9.12
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/trove-classifiers')
-rw-r--r--dev-python/trove-classifiers/Manifest1
-rw-r--r--dev-python/trove-classifiers/trove-classifiers-2024.9.12.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/trove-classifiers/Manifest b/dev-python/trove-classifiers/Manifest
index faabc5757088..5194bf84b768 100644
--- a/dev-python/trove-classifiers/Manifest
+++ b/dev-python/trove-classifiers/Manifest
@@ -1 +1,2 @@
DIST trove_classifiers-2024.7.2.tar.gz 16071 BLAKE2B 6f13df1498b68e2f24838473ad8b6feb341e33da6eabc2e104c823e6db65ada348ef36c8fd96226818d89c11bf0b0ac9665c9a6ecbea5ba620d2e48c64c5b82f SHA512 af9a366425e845b1bbd098c8085ec8064dbf6864940c7dd5def1672c2046756e2c76255b282b2c989c34d14b113b7c6abd32d23eeed88317d374043040f46486
+DIST trove_classifiers-2024.9.12.tar.gz 16058 BLAKE2B 6cac2247910e95bf1f0b9a37b0f0e59062652526a45c4097c743a5f0665a5d8b5042bb7eb02741f2bf9b7d669a1be238940ab2b498281ef3ce6f3fa4c0c2961c SHA512 4fc6efc514638dfb2aee4fbd06f258bb9d5d9d54269e6d33f3739a63d61d6d3caa9a7124f9e5ad601714253c27b97bc9a60f3a9369f2f358ed19fbdfcefcbb10
diff --git a/dev-python/trove-classifiers/trove-classifiers-2024.9.12.ebuild b/dev-python/trove-classifiers/trove-classifiers-2024.9.12.ebuild
new file mode 100644
index 000000000000..0fb0bac459d4
--- /dev/null
+++ b/dev-python/trove-classifiers/trove-classifiers-2024.9.12.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Canonical source for classifiers on PyPI (pypi.org)"
+HOMEPAGE="
+ https://github.com/pypa/trove-classifiers/
+ https://pypi.org/project/trove-classifiers/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ grep -q 'build-backend = "setuptools' pyproject.toml ||
+ die "Upstream changed build-backend, recheck"
+ # write a custom pyproject.toml to ease hatchling bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "trove-classifiers"
+ version = "${PV}"
+ description = "Canonical source for classifiers on PyPI (pypi.org)."
+ EOF
+}
+
+python_test() {
+ epytest
+ "${EPYTHON}" -m tests.lib || die
+}