summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-11 09:27:08 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-11 09:49:15 +0100
commitec8311e43cdde954c98e78f0f5ac20a561d3cdf1 (patch)
treeb2aa5795024df8c526825a2f7e60541a17be4f44 /dev-python/toml
parentdev-python/versioneer: Bump to 0.19 (diff)
downloadgentoo-ec8311e43cdde954c98e78f0f5ac20a561d3cdf1.tar.gz
gentoo-ec8311e43cdde954c98e78f0f5ac20a561d3cdf1.tar.bz2
gentoo-ec8311e43cdde954c98e78f0f5ac20a561d3cdf1.zip
dev-python/toml: Bump to 0.10.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/toml')
-rw-r--r--dev-python/toml/Manifest1
-rw-r--r--dev-python/toml/toml-0.10.2.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/toml/Manifest b/dev-python/toml/Manifest
index 1b62b1b49f59..1a21f124aefd 100644
--- a/dev-python/toml/Manifest
+++ b/dev-python/toml/Manifest
@@ -1,2 +1,3 @@
DIST toml-0.10.1-1.tar.gz 22559 BLAKE2B 17d9d9c78f2b78a6fc5bc0efd8530af5514d2f965eb1896a0eaca9a6d8ce1dda3a5dc825a8b6cd2a2096a582bd35952e6f0a3372021c739c69186d5a2c5642be SHA512 0a2348bffc889e63f4c6f8ae4faf022cceff069b178d086a37ff03e97e0f24b4b5a72810a345692f21810f3f41908b6981da902862adb06286bdb2941e9e0d60
+DIST toml-0.10.2-1.tar.gz 23325 BLAKE2B dedab7d08dadca963e62d64e9108e254dd73b78761985faa892792823027befc6473ae02c35c275a216b4544d1af8776afa78e39c63c95eb856e2bccf1de49c4 SHA512 5c706a3ae336e6b29bdce9752b91c677f7610cbcc1af4169cc24779e248031406cd19ac367725b2aa7903e4b1db71fa59255238c0270b2c146fd5d7e12d9a5da
DIST toml-test-280497fa5f12e43d7233aed0d74e07ca61ef176b.tar.gz 19593 BLAKE2B e9deba7c5d1eea7bd87fcf5e5c74bda4c2b9e9686e597e3ad51516f60eb8d192fb01d052ac57729c6f0851e2715cc6409a904affd637c9b099cabc1b12ad5d52 SHA512 7bd69b8c14f09bf431094b52d988eb233922527719ba5047ff769d2e709c2039fb6fb1c8144e630ad2a58835d19e0e4cc51433a427596d37f8eccb6d73d7e5c0
diff --git a/dev-python/toml/toml-0.10.2.ebuild b/dev-python/toml/toml-0.10.2.ebuild
new file mode 100644
index 000000000000..2e0e4cab9bb6
--- /dev/null
+++ b/dev-python/toml/toml-0.10.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+
+inherit distutils-r1
+
+TOML_TEST_VER="280497fa5f12e43d7233aed0d74e07ca61ef176b"
+
+DESCRIPTION="Python library for handling TOML files"
+HOMEPAGE="https://github.com/uiri/toml"
+SRC_URI="https://github.com/uiri/${PN}/archive/${PV}.tar.gz -> ${P}-1.tar.gz
+ test? ( https://github.com/BurntSushi/toml-test/archive/${TOML_TEST_VER}.tar.gz -> toml-test-${TOML_TEST_VER}.tar.gz )"
+IUSE="test"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/numpy[${PYTHON_USEDEP}]
+ ' 'python*')
+ )"
+
+DOCS=( README.rst )
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ if use test; then
+ mv "${WORKDIR}/toml-test-${TOML_TEST_VER#v}" "${S}/toml-test" || die
+ fi
+
+ distutils-r1_python_prepare_all
+}