summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-02-06 13:18:20 +0100
committerBenda Xu <heroxbd@gentoo.org>2020-02-14 10:57:09 +0800
commit42b1924a9bd4f433207f0e21a47127bd9b5a7b3f (patch)
treee30868ab3e27af87343095684bebc4274e7fa28c /dev-python/tikzplotlib
parentgames-puzzle/tod: add patch to fix fixed point math functions (diff)
downloadgentoo-42b1924a9bd4f433207f0e21a47127bd9b5a7b3f.tar.gz
gentoo-42b1924a9bd4f433207f0e21a47127bd9b5a7b3f.tar.bz2
gentoo-42b1924a9bd4f433207f0e21a47127bd9b5a7b3f.zip
dev-python/tikzplotlib: Version bump 0.9.1
- Renamed from matplotlib2tikz - Added py3_7 - Fixed IUSE="test" - Added IUSE="doc" - dev-python/matplotlib2tikz: Renamed to tikzplotlib - profile/updates: matplotlib2tikz to tikzplotlib Closes: https://bugs.gentoo.org/695716 Closes: https://github.com/gentoo/gentoo/pull/14579 Signed-off-by: Benda Xu <heroxbd@gentoo.org>
Diffstat (limited to 'dev-python/tikzplotlib')
-rw-r--r--dev-python/tikzplotlib/Manifest1
-rw-r--r--dev-python/tikzplotlib/metadata.xml13
-rw-r--r--dev-python/tikzplotlib/tikzplotlib-0.9.1.ebuild42
3 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/tikzplotlib/Manifest b/dev-python/tikzplotlib/Manifest
new file mode 100644
index 000000000000..9d2e25fabe2f
--- /dev/null
+++ b/dev-python/tikzplotlib/Manifest
@@ -0,0 +1 @@
+DIST tikzplotlib-0.9.1.tar.gz 584961 BLAKE2B 62737db9117c96484de690b26c3f13d5a872a3c70ad4ebe635bcba348dfa7f0eb944b8c469807c4c474351a9fae7db6dd71df82e33ee33cbdd8b1abeb9686e1b SHA512 10f3be8b843ea81d48bd6fad494a7e7a0cc5afd45a96c26be7f4dfbac929bdb3010fd355c6e1ef262273fd0783fc5b5b4a7b41a0c01e18cff5446bb9d96ee2b7
diff --git a/dev-python/tikzplotlib/metadata.xml b/dev-python/tikzplotlib/metadata.xml
new file mode 100644
index 000000000000..50a33145b076
--- /dev/null
+++ b/dev-python/tikzplotlib/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription>tikzplotlib is a Python tool for converting matplotlib figures into PGFPlots (TikZ) figures like for native inclusion into LaTeX documents. The output of tikzplotlib is in PGFPlots, a LaTeX library that sits on top of TikZ and describes graphs in terms of axes, data etc. Consequently, the output of tikzplotlib retains more information, can be more easily understood, and is more easily editable than raw TikZ output.</longdescription>
+ <upstream>
+ <remote-id type="github">nschloe/tikzplotlib</remote-id>
+ <remote-id type="pypi">tikzplotlib</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/tikzplotlib/tikzplotlib-0.9.1.ebuild b/dev-python/tikzplotlib/tikzplotlib-0.9.1.ebuild
new file mode 100644
index 000000000000..9bd714fa2fe7
--- /dev/null
+++ b/dev-python/tikzplotlib/tikzplotlib-0.9.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Convert matplotlib figures into TikZ/PGFPlots"
+HOMEPAGE="https://github.com/nschloe/tikzplotlib"
+SRC_URI="https://github.com/nschloe/tikzplotlib/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]"
+
+DEPEND="test? (
+ dev-python/pandas[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc dev-python/mock
+
+python_prepare_all() {
+ # this test fails: tikz error
+ # cannot mix dimensions and dimensionless values in an ellipse
+ rm test/test_patches.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x MPLBACKEND=Agg
+ virtx pytest -vv
+}