summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2020-04-06 08:35:26 +0300
committerMikle Kolyada <zlogene@gentoo.org>2020-04-06 08:38:06 +0300
commit7622f900c65bed93baa22c98c8b09cce1af77e64 (patch)
treefdb9fda6b1291d0ed16223e0968f7ab337335890 /dev-python/testify
parentnet-news/newsboat: unmaintain (diff)
downloadgentoo-7622f900c65bed93baa22c98c8b09cce1af77e64.tar.gz
gentoo-7622f900c65bed93baa22c98c8b09cce1af77e64.tar.bz2
gentoo-7622f900c65bed93baa22c98c8b09cce1af77e64.zip
dev-python: mass last-rites removal
Closes: https://bugs.gentoo.org/711808 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'dev-python/testify')
-rw-r--r--dev-python/testify/Manifest1
-rw-r--r--dev-python/testify/metadata.xml12
-rw-r--r--dev-python/testify/testify-0.11.0.ebuild46
3 files changed, 0 insertions, 59 deletions
diff --git a/dev-python/testify/Manifest b/dev-python/testify/Manifest
deleted file mode 100644
index 8c1b3d9c41b6..000000000000
--- a/dev-python/testify/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST testify-0.11.0.tar.gz 67914 BLAKE2B 8518f7f95ed83c7c8d779b58962f9b111639b4d5b9bbe80907a6e25ca70781945aa320a0cdcfefebe6c96b0a7f471f8334af332dad32beab5848e7601ed277e0 SHA512 ed19a9b5cfa509b65bfa366aa8c5fb311f00a2996dca9b5028a7dfe8d7ad06ab88964dd7e7ea7aa31e183537d769bbd81eb6dbd7d57d7576b6ec8fca9b684dd0
diff --git a/dev-python/testify/metadata.xml b/dev-python/testify/metadata.xml
deleted file mode 100644
index 643f2eb0cc32..000000000000
--- a/dev-python/testify/metadata.xml
+++ /dev/null
@@ -1,12 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <upstream>
- <remote-id type="pypi">testify</remote-id>
- <remote-id type="github">Yelp/testify</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-python/testify/testify-0.11.0.ebuild b/dev-python/testify/testify-0.11.0.ebuild
deleted file mode 100644
index f3bdc14470bc..000000000000
--- a/dev-python/testify/testify-0.11.0.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1 vcs-snapshot
-
-DESCRIPTION="A more pythonic replacement for the unittest module and nose"
-HOMEPAGE="https://github.com/Yelp/testify https://pypi.org/project/testify/"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/sqlalchemy[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- www-servers/tornado[${PYTHON_USEDEP}]
- >=dev-python/six-1.7.3[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( ${RDEPEND} )"
-
-python_prepare_all() {
- # Correct typo in setup.py
- sed -e 's:mock,:mock:' -i setup.py || die
-
- # Correct use of local importing in pertinent test_ files
- sed -e s':from .test:from test:' \
- -i test/test_runner_test.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- einfo; einfo "Output reporting exceptions \"ImportError: No module named <module>\""
- einfo "are instances of exceptions expected to be raised, similar to xfails by nose"; einfo""
- for test in test/test_*_test.py;
- do
- "${PYTHON}" $test || die "test $test failed under ${EPYTHON}"
- done
-}