summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-26 06:38:52 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-26 06:49:54 +0200
commit864543cafd05d9ce3e500f7cc83c26c23f2ad67f (patch)
tree29749b1d03bede9c50e4414db44dd2bac6f7ba9c /dev-python/tempest
parentdev-python/prompt-toolkit: Bump to 3.0.48 (diff)
downloadgentoo-864543cafd05d9ce3e500f7cc83c26c23f2ad67f.tar.gz
gentoo-864543cafd05d9ce3e500f7cc83c26c23f2ad67f.tar.bz2
gentoo-864543cafd05d9ce3e500f7cc83c26c23f2ad67f.zip
dev-python/tempest: Bump to 41.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tempest')
-rw-r--r--dev-python/tempest/Manifest1
-rw-r--r--dev-python/tempest/tempest-41.0.0.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/dev-python/tempest/Manifest b/dev-python/tempest/Manifest
index 6df52ea819d6..f90d0809ac4d 100644
--- a/dev-python/tempest/Manifest
+++ b/dev-python/tempest/Manifest
@@ -1,2 +1,3 @@
DIST tempest-39.0.0.tar.gz 1156891 BLAKE2B 8f4d4026f3b304b713d97a511ba85363ed39dde22ef6c529b75ba35d01619eca925cc759d899f16b791784cd0c1d7acaa78e8361189dd5167de8300e26d5e74e SHA512 4e60b7fe90b7943cb9208cab72188f3f3668fdc4fd90b4667e5f578f979f66dbc6e9a2486c47fb7f0f608ac8197b726da1fd6b7ded169d804705dc4e58eed256
DIST tempest-40.0.0.tar.gz 1149624 BLAKE2B e75db763090738032699c35477a5bc5d877c44aed1ed4e9fe7b878af116dc6d53dd7b64cf58be55cd3448f5ebdf8e9a44e3f4deb215f535784a33abfc79fde9d SHA512 12227d4f20045f60e56db7bc1de3e117ddbc3d4b3e30aa26239795675023b23facf15646f1c048b75f43dd9c0ba5e7d475e8ad1c483b2d0e32ef9d8d50e62dfc
+DIST tempest-41.0.0.tar.gz 1151830 BLAKE2B 6c732647f49a07d1ae747a4f286779b21c1c64f046a8542cf3f067f79cc839d99fcc6eced01162f5e0415e803c8a2ee0a0e5e5ec92f1088736cff3b341874b9f SHA512 aa5065dbb7431b5cf5d93075083e74eb6c811c759f109ac9ceee7cc45240b84c091f84542a3455cf686f84e359a17f99154ec417ee7003bb01c7ef191f6dcc27
diff --git a/dev-python/tempest/tempest-41.0.0.ebuild b/dev-python/tempest/tempest-41.0.0.ebuild
new file mode 100644
index 000000000000..c8907a75cbcb
--- /dev/null
+++ b/dev-python/tempest/tempest-41.0.0.ebuild
@@ -0,0 +1,75 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 multiprocessing pypi
+
+DESCRIPTION="OpenStack Integration Testing"
+HOMEPAGE="
+ https://pypi.org/project/tempest/
+ https://docs.openstack.org/tempest/latest/
+ https://launchpad.net/tempest/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ >dev-python/cliff-2.9.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/paramiko-2.7.0[${PYTHON_USEDEP}]
+ >=dev-python/netaddr-0.7.18[${PYTHON_USEDEP}]
+ >=dev-python/oslo-concurrency-3.26.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-3.36.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-4.7.0[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12[${PYTHON_USEDEP}]
+ >=dev-python/subunit-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.21.1[${PYTHON_USEDEP}]
+ >=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/defusedxml-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/fasteners-0.16.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.5.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ dev-python/stestr[${PYTHON_USEDEP}]
+ )
+"
+
+src_prepare() {
+ # Small subset of tests, which fail as result of not using specific
+ # testing environment.
+ rm -r tempest/tests/lib/services/volume/v3/ || die
+
+ # remove dep on hacking
+ rm tempest/tests/test_hacking.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ mv "${BUILD_DIR}"/install/{usr/,}etc || die
+}
+
+python_test() {
+ local -x OS_LOG_CAPTURE=1 OS_STDOUT_CAPTURE=1 OS_STDERR_CAPTURE=1
+ local -x OS_TEST_TIMEOUT=300
+ stestr --test-path ./tempest/tests run --concurrency="$(makeopts_jobs)" ||
+ die "Tests failed for ${EPYTHON}"
+}