summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-22 08:47:03 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-22 09:36:58 +0200
commitae13245db82423503194ccbb300bf29c58767665 (patch)
tree177387a1b011737554518fbbd16a475b3ade48c3 /dev-python/stestr
parentdev-python/pikepdf: Bump to 3.1.0 (diff)
downloadgentoo-ae13245db82423503194ccbb300bf29c58767665.tar.gz
gentoo-ae13245db82423503194ccbb300bf29c58767665.tar.bz2
gentoo-ae13245db82423503194ccbb300bf29c58767665.zip
dev-python/stestr: Bump to 3.2.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/stestr')
-rw-r--r--dev-python/stestr/Manifest1
-rw-r--r--dev-python/stestr/stestr-3.2.1.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/stestr/Manifest b/dev-python/stestr/Manifest
index fca596b5bf1f..def344399bf1 100644
--- a/dev-python/stestr/Manifest
+++ b/dev-python/stestr/Manifest
@@ -1,2 +1,3 @@
DIST stestr-2.1.0.tar.gz 103501 BLAKE2B 6b000b8e3d0a27a18f19510dd8d5de8641223c18ad22a3f90b73619aa41bbe1a51bcedba604ec448282fa41e2ae93b61fdd0e72e603a39730a59400fc15ef007 SHA512 a99d0659da0ca2b86703529df9ef6d135578bd8374a2afcbd10bd96f24f5e6dd1dacd5929d96a083881f1db2a930b039d9045348a0298d84d2480c6c9a75d1f7
DIST stestr-3.2.0.tar.gz 118000 BLAKE2B 901654b53fdc9e5ab287b77b0a26ce531e3a167b2f5d0aa0765de170341bac8ebfbc4efcae39f672ca6dc6f7518913cb5e56d87faaef35c0b06287652c06edb1 SHA512 4f5e41c92518104b06f5b9717d59c214a8d87efe47fee199a602e71efd64e29c98711ffcf3b88cd00209946d0ab123c7ec5aa842e1d54bc65d83c8d70fa4898c
+DIST stestr-3.2.1.tar.gz 118139 BLAKE2B dedb63767adfab26d837ce92762dcc44a482b1772aecbc31d12beb22f2c3c08368475cd110de7376f4df7fa8ce03c5b8e3b04436296ad4bd11c2fc3a4243695b SHA512 43187ca0d81e3b31e16ed60a1db561dc49c34f679594d11cad8cb0e658bf790af0b3d606bf99233a5767e2511675d3aedb6a476046d2f5483ffab05eaae393ed
diff --git a/dev-python/stestr/stestr-3.2.1.ebuild b/dev-python/stestr/stestr-3.2.1.ebuild
new file mode 100644
index 000000000000..bc0a9302626e
--- /dev/null
+++ b/dev-python/stestr/stestr-3.2.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="A parallel Python test runner built around subunit"
+HOMEPAGE="https://github.com/mtreinish/stestr"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ dev-python/future[${PYTHON_USEDEP}]
+ >=dev-python/cliff-2.8.0[${PYTHON_USEDEP}]
+ >=dev-python/subunit-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.10.0[${PYTHON_USEDEP}]
+ >=dev-python/voluptuous-0.8.9[${PYTHON_USEDEP}]"
+BDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/ddt-1.0.1[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ distutils_install_for_testing
+ stestr init || die
+ stestr run || die "Tests failed with ${EPYTHON}"
+}