summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-09-05 13:55:07 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-09-05 14:10:47 +0200
commitf6e5b6798c23e88a3600c326ac7b0c3f1b31483f (patch)
treee68cbb205a639d063a4b7c6f5eedb237134d56eb /dev-python/spyder-unittest
parentsys-kernel/vanilla-sources: add 5.4.212, drop 5.4.211 (diff)
downloadgentoo-f6e5b6798c23e88a3600c326ac7b0c3f1b31483f.tar.gz
gentoo-f6e5b6798c23e88a3600c326ac7b0c3f1b31483f.tar.bz2
gentoo-f6e5b6798c23e88a3600c326ac7b0c3f1b31483f.zip
dev-python/spyder-unittest: add 0.5.1
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/spyder-unittest')
-rw-r--r--dev-python/spyder-unittest/Manifest1
-rw-r--r--dev-python/spyder-unittest/spyder-unittest-0.5.1.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/spyder-unittest/Manifest b/dev-python/spyder-unittest/Manifest
index 22be279e4c0c..62e90be9ac19 100644
--- a/dev-python/spyder-unittest/Manifest
+++ b/dev-python/spyder-unittest/Manifest
@@ -1 +1,2 @@
DIST spyder-unittest-0.5.0.tar.gz 80022 BLAKE2B c904196f7b0288b4d4f105037cbf75fc7ef60669ba1a24687b4f6aa672b88b139b64282c2d12340c958a3ffb65b8cf01b61256f669e167a6c15eb9471430af2a SHA512 4bea5d88b6be80435e2fa6498803ceea275b72c47bd0a54bb3be962bfe00feed2073e4d4915ea1b4dd780cb1c104f6dcd2735ee000cdedb934ed9fac059d0ca5
+DIST spyder-unittest-0.5.1.gh.tar.gz 80022 BLAKE2B c904196f7b0288b4d4f105037cbf75fc7ef60669ba1a24687b4f6aa672b88b139b64282c2d12340c958a3ffb65b8cf01b61256f669e167a6c15eb9471430af2a SHA512 4bea5d88b6be80435e2fa6498803ceea275b72c47bd0a54bb3be962bfe00feed2073e4d4915ea1b4dd780cb1c104f6dcd2735ee000cdedb934ed9fac059d0ca5
diff --git a/dev-python/spyder-unittest/spyder-unittest-0.5.1.ebuild b/dev-python/spyder-unittest/spyder-unittest-0.5.1.ebuild
new file mode 100644
index 000000000000..abd29d2cb968
--- /dev/null
+++ b/dev-python/spyder-unittest/spyder-unittest-0.5.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 virtualx
+
+COMMIT="d210d9fe6c4efbb21d680a040cc4741d76a81f49"
+
+DESCRIPTION="Plugin for Spyder to run tests and view the results"
+HOMEPAGE="https://github.com/spyder-ide/spyder-unittest"
+SRC_URI="https://github.com/spyder-ide/${PN}/archive/${COMMIT}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+# AttributeError: 'NoneType' object has no attribute 'split'
+RESTRICT="test"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/spyder-5.3.1[${PYTHON_USEDEP}]
+ <dev-python/spyder-6[${PYTHON_USEDEP}]
+ dev-python/pyzmq[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+"
+
+DEPEND="test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-qt[${PYTHON_USEDEP}]
+)"
+
+distutils_enable_tests pytest
+
+python_test() {
+ virtx epytest
+}