summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2017-08-02 02:20:34 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2017-08-02 04:06:25 +0000
commit855cfa75313c24c6b6e55a7f60d5e2f4edda9c99 (patch)
treeed18da2816dbc87892f2206fde3c769da1fd54f4 /dev-python/sphinxcontrib-newsfeed
parentdev-python/sphinxcontrib-napoleon: version bump (diff)
downloadgentoo-855cfa75313c24c6b6e55a7f60d5e2f4edda9c99.tar.gz
gentoo-855cfa75313c24c6b6e55a7f60d5e2f4edda9c99.tar.bz2
gentoo-855cfa75313c24c6b6e55a7f60d5e2f4edda9c99.zip
dev-python/sphinxcontrib-newsfeed: fix for sphinxcontrib namespace, added prefix and x86
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-python/sphinxcontrib-newsfeed')
-rw-r--r--dev-python/sphinxcontrib-newsfeed/sphinxcontrib-newsfeed-0.1.4.ebuild15
1 files changed, 10 insertions, 5 deletions
diff --git a/dev-python/sphinxcontrib-newsfeed/sphinxcontrib-newsfeed-0.1.4.ebuild b/dev-python/sphinxcontrib-newsfeed/sphinxcontrib-newsfeed-0.1.4.ebuild
index b31cfd58c28b..b53938a825e9 100644
--- a/dev-python/sphinxcontrib-newsfeed/sphinxcontrib-newsfeed-0.1.4.ebuild
+++ b/dev-python/sphinxcontrib-newsfeed/sphinxcontrib-newsfeed-0.1.4.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
inherit distutils-r1
@@ -12,14 +12,19 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD-2"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="examples"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="dev-python/sphinx[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]"
python_install_all() {
- use examples && local EXAMPLES=( demo/. )
-
distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r demo/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
}