summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-03 18:20:14 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-03 18:30:53 +0100
commitfeca4fdecfe07d245d9c8d46386be31996d5743b (patch)
treed336751c913a0a976b9fa87fff1db2ad17d4cf8a /dev-python/sphinxcontrib-httpexample/sphinxcontrib-httpexample-0.10.3.ebuild
parentdev-python/sphinxcontrib-httpdomain: Remove namespace dep (diff)
downloadgentoo-feca4fdecfe07d245d9c8d46386be31996d5743b.tar.gz
gentoo-feca4fdecfe07d245d9c8d46386be31996d5743b.tar.bz2
gentoo-feca4fdecfe07d245d9c8d46386be31996d5743b.zip
dev-python/sphinxcontrib-httpexample: Remove namespace dep
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sphinxcontrib-httpexample/sphinxcontrib-httpexample-0.10.3.ebuild')
-rw-r--r--dev-python/sphinxcontrib-httpexample/sphinxcontrib-httpexample-0.10.3.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/dev-python/sphinxcontrib-httpexample/sphinxcontrib-httpexample-0.10.3.ebuild b/dev-python/sphinxcontrib-httpexample/sphinxcontrib-httpexample-0.10.3.ebuild
deleted file mode 100644
index 62cfbf4fe443..000000000000
--- a/dev-python/sphinxcontrib-httpexample/sphinxcontrib-httpexample-0.10.3.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8} )
-inherit distutils-r1
-
-DESCRIPTION="Adds example directive for sphinx-contrib httpdomain"
-HOMEPAGE="https://github.com/collective/sphinxcontrib-httpexample"
-SRC_URI="https://github.com/collective/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/astunparse[${PYTHON_USEDEP}]
- dev-python/docutils[${PYTHON_USEDEP}]
- dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/sphinxcontrib-httpdomain[${PYTHON_USEDEP}]
-"
-BDEPEND="${RDEPEND}
- test? (
- dev-python/snapshottest[${PYTHON_USEDEP}]
- dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
- dev-python/sphinx-testing[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- sed -e "s:pytest-runner::" -i setup.cfg || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- distutils_install_for_testing
- pytest -vv || die "tests fail with ${EPYTHON}"
-}