summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-27 09:15:43 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-27 09:49:21 +0100
commit35d25c3ab8279029e00bba4177c5721d2edfb3df (patch)
tree0ed25d6290a6e87db8adb87d2a8746e107e26523 /dev-python/sphinx_ansible_theme
parentapp-admin/awscli: Bump to 1.22.44 (diff)
downloadgentoo-35d25c3ab8279029e00bba4177c5721d2edfb3df.tar.gz
gentoo-35d25c3ab8279029e00bba4177c5721d2edfb3df.tar.bz2
gentoo-35d25c3ab8279029e00bba4177c5721d2edfb3df.zip
dev-python/sphinx_ansible_theme: Bump to 0.9.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sphinx_ansible_theme')
-rw-r--r--dev-python/sphinx_ansible_theme/Manifest1
-rw-r--r--dev-python/sphinx_ansible_theme/sphinx_ansible_theme-0.9.1.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/sphinx_ansible_theme/Manifest b/dev-python/sphinx_ansible_theme/Manifest
index 32fdcfc9f05d..4802a02e7a5a 100644
--- a/dev-python/sphinx_ansible_theme/Manifest
+++ b/dev-python/sphinx_ansible_theme/Manifest
@@ -1,2 +1,3 @@
DIST sphinx-ansible-theme-0.8.0.tar.gz 34401 BLAKE2B 493663331e593da8d56683991762452419fd5fdb48e2c59ee3a38b6242216bccf56e047e59294ae73cccfb48a66606e55fac6c9a19d91e6ea778920f9919dbd1 SHA512 399af992428dd3212681efa66036af9ae7dbd9a9dd507452686cc76aa3e365aabee0ba7b599fbbed85f1f252075d5158ade9a816a9aad17b4e5ed696be1c962e
DIST sphinx-ansible-theme-0.9.0.tar.gz 34533 BLAKE2B 53e4169f8deb88c9b0398e745cb249a596b3e63086afd3543d2465e1f2048f587f0a5964ac4a4cdc7a81c2cf78239ec59cd808a4dd644b3faec39b7a2b6487cd SHA512 0610a8422950252d88469dde274e3ac3df85034a886e87dbc9a19d621a55a7fc45d8ffdaf047cf78c556d6eacc09832d718fa5ab8f5019621b37579d84ed4951
+DIST sphinx-ansible-theme-0.9.1.tar.gz 34505 BLAKE2B 533e665b30f5aa450e4a2240c55c4992340b9f6ee03d27758bf119dfe2eef987fbd4b98136349af376557d8e9a78e5391a648b9886136995d05410b0c26561f2 SHA512 f78602af8affe7be59988f466cf6a2aa67e174086f338cad855369a7bbee5a76d07bcffa8406dea5a819127b26d69e29b0d90dab38b82524b3e317f9082d0379
diff --git a/dev-python/sphinx_ansible_theme/sphinx_ansible_theme-0.9.1.ebuild b/dev-python/sphinx_ansible_theme/sphinx_ansible_theme-0.9.1.ebuild
new file mode 100644
index 000000000000..60343704c810
--- /dev/null
+++ b/dev-python/sphinx_ansible_theme/sphinx_ansible_theme-0.9.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_PN="${PN//_/-}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A reusable Ansible Sphinx theme"
+HOMEPAGE="https://github.com/ansible-community/sphinx_ansible_theme"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S="${WORKDIR}"/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="
+ dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm_git_archive[${PYTHON_USEDEP}]
+ doc? ( dev-python/ansible-pygments[${PYTHON_USEDEP}] )"
+
+distutils_enable_sphinx docs 'dev-python/sphinx-notfound-page'