summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-04 13:10:13 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-04 14:00:40 +0200
commit4ee7fe8463cfc40961934755ae9d9b2be09f533c (patch)
tree977a818e3233ca4bdd3d9cd1cb884ed2c8cf4249 /dev-python/sphinx
parentdev-python/sphinxcontrib-qthelp: Enable py3.10 (diff)
downloadgentoo-4ee7fe8463cfc40961934755ae9d9b2be09f533c.tar.gz
gentoo-4ee7fe8463cfc40961934755ae9d9b2be09f533c.tar.bz2
gentoo-4ee7fe8463cfc40961934755ae9d9b2be09f533c.zip
dev-python/sphinx: Enable py3.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sphinx')
-rw-r--r--dev-python/sphinx/files/sphinx-4.0.2-py310.patch28
-rw-r--r--dev-python/sphinx/sphinx-4.0.2.ebuild3
2 files changed, 30 insertions, 1 deletions
diff --git a/dev-python/sphinx/files/sphinx-4.0.2-py310.patch b/dev-python/sphinx/files/sphinx-4.0.2-py310.patch
new file mode 100644
index 000000000000..db0facafed5f
--- /dev/null
+++ b/dev-python/sphinx/files/sphinx-4.0.2-py310.patch
@@ -0,0 +1,28 @@
+From 531a5ae9ef855761407d44fb49064ae6227868f5 Mon Sep 17 00:00:00 2001
+From: Takeshi KOMIYA <i.tkomiya@gmail.com>
+Date: Wed, 5 May 2021 22:11:41 +0900
+Subject: [PATCH] test: Adjust type annotataions in python 3.10.0b1
+
+---
+ tests/test_util_inspect.py | 5 +----
+ 1 file changed, 1 insertion(+), 4 deletions(-)
+
+diff --git a/tests/test_util_inspect.py b/tests/test_util_inspect.py
+index 7b86c6ade..8df06a865 100644
+--- a/tests/test_util_inspect.py
++++ b/tests/test_util_inspect.py
+@@ -183,10 +183,7 @@ def test_signature_annotations():
+
+ # Instance annotations
+ sig = inspect.signature(f11)
+- if sys.version_info < (3, 10):
+- assert stringify_signature(sig) == '(x: CustomAnnotation, y: 123) -> None'
+- else:
+- assert stringify_signature(sig) == '(x: CustomAnnotation(), y: 123) -> None'
++ assert stringify_signature(sig) == '(x: CustomAnnotation, y: 123) -> None'
+
+ # tuple with more than two items
+ sig = inspect.signature(f12)
+--
+2.31.1
+
diff --git a/dev-python/sphinx/sphinx-4.0.2.ebuild b/dev-python/sphinx/sphinx-4.0.2.ebuild
index 1c6f8a61729a..7cc217f2e354 100644
--- a/dev-python/sphinx/sphinx-4.0.2.ebuild
+++ b/dev-python/sphinx/sphinx-4.0.2.ebuild
@@ -4,7 +4,7 @@
EAPI=7
DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{7..9} pypy3 )
+PYTHON_COMPAT=( python3_{7..10} pypy3 )
PYTHON_REQ_USE="threads(+)"
inherit distutils-r1
@@ -60,6 +60,7 @@ BDEPEND="
PATCHES=(
"${FILESDIR}/${PN}-3.2.1-doc-link.patch"
+ "${FILESDIR}/${P}-py310.patch"
)
distutils_enable_tests pytest