summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-20 06:37:36 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-20 06:45:49 +0200
commitd3f7386603e4846e8002465e0644b8605c936ccb (patch)
tree0f7f0e229303d5e77cca6439851f25370abb1b3a /dev-python/sphinx-autodoc-typehints
parentdev-python/mkdocstrings-python: Bump to 1.10.5 (diff)
downloadgentoo-d3f7386603e4846e8002465e0644b8605c936ccb.tar.gz
gentoo-d3f7386603e4846e8002465e0644b8605c936ccb.tar.bz2
gentoo-d3f7386603e4846e8002465e0644b8605c936ccb.zip
dev-python/sphinx-autodoc-typehints: Bump to 2.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sphinx-autodoc-typehints')
-rw-r--r--dev-python/sphinx-autodoc-typehints/Manifest1
-rw-r--r--dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-2.2.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/sphinx-autodoc-typehints/Manifest b/dev-python/sphinx-autodoc-typehints/Manifest
index 8bd48b726f11..8fabe3b71114 100644
--- a/dev-python/sphinx-autodoc-typehints/Manifest
+++ b/dev-python/sphinx-autodoc-typehints/Manifest
@@ -1 +1,2 @@
DIST sphinx_autodoc_typehints-2.1.0.tar.gz 39386 BLAKE2B ccf6b618fc3db2a576a2d9a36a575087cdc3c7c5cf59a6057a956478a12715b1623dc4bc1ae3f7c30deab317a15fa187faf19f9d050fa61c293dc20bee41effd SHA512 59c5b4c682fadc1d0ec62a5aa639bb87d6e4710db89793824c348c7598d73b144f0b083ce6462ea32d958b1ed7fd2fb96c2a92780267adef03b625e64c08c412
+DIST sphinx_autodoc_typehints-2.2.0.tar.gz 39603 BLAKE2B 42286d62684a3fdb9949f9e4af56aece11b93b8b5e78be06df03389ceec7fdb99f4baa1ddd46facaa8cb85900655ddae08056fef44a73dc21f29fd87540dacfc SHA512 24c2cc40c56656cc85006e96341d57d46228a67524f4cbc13724fdbd1c0a5a2c41b08e170e217ac5198330fb70539514735b60c34eb84ea15717c38bb95b0adf
diff --git a/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-2.2.0.ebuild b/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-2.2.0.ebuild
new file mode 100644
index 000000000000..f6053e2167f7
--- /dev/null
+++ b/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-2.2.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Type hints support for the Sphinx autodoc extension"
+HOMEPAGE="
+ https://github.com/tox-dev/sphinx-autodoc-typehints/
+ https://pypi.org/project/sphinx-autodoc-typehints/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/sphinx-7.1.2[${PYTHON_USEDEP}]
+"
+# skipping optional test dep on dev-python/nptyping as that package
+# is horribly broken and on its way out
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/sphobjinv-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-4.5[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # this package is addicted to Internet
+ tests/test_sphinx_autodoc_typehints.py::test_format_annotation
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}