summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2024-05-30 15:51:06 +0200
committerFlorian Schmaus <flow@gentoo.org>2024-05-30 18:52:21 +0200
commit869cf63e98ceb1490ad1824498f9d8ffdeb0c447 (patch)
tree3328ae9d51c548f91981bba1cacded8aab698233 /dev-python/slixmpp
parentnet-p2p/transmission: remove errant file (diff)
downloadgentoo-869cf63e98ceb1490ad1824498f9d8ffdeb0c447.tar.gz
gentoo-869cf63e98ceb1490ad1824498f9d8ffdeb0c447.tar.bz2
gentoo-869cf63e98ceb1490ad1824498f9d8ffdeb0c447.zip
dev-python/slixmpp: sync live
Closes: https://bugs.gentoo.org/929509 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'dev-python/slixmpp')
-rw-r--r--dev-python/slixmpp/slixmpp-9999.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/dev-python/slixmpp/slixmpp-9999.ebuild b/dev-python/slixmpp/slixmpp-9999.ebuild
index 58e07cc7ebc8..03eca9ed9e90 100644
--- a/dev-python/slixmpp/slixmpp-9999.ebuild
+++ b/dev-python/slixmpp/slixmpp-9999.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_EXT=1
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1
@@ -22,7 +22,7 @@ if [[ "${PV}" == "9999" ]]; then
inherit git-r3
else
inherit pypi
- KEYWORDS="~amd64 ~riscv"
+ KEYWORDS="amd64 ~riscv"
fi
DEPEND="
@@ -36,6 +36,9 @@ RDEPEND="
dev-python/pyasn1-modules[${PYTHON_USEDEP}]
dev-python/pyasn1[${PYTHON_USEDEP}]
${DEPEND}
+ $(python_gen_cond_dep '
+ >=dev-lang/python-3.12.1_p1:3.12
+ ' python3_12)
"
BDEPEND="
dev-python/cython[${PYTHON_USEDEP}]