summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-23 13:34:03 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-23 13:35:43 +0200
commit2883c689d2f26e974b219a1bc04129541f888770 (patch)
treecd5d2f929581e9279a8a7d76b410f73b984082ed /dev-python/slimit
parentdev-python/sexpdata: Enable py3.9 & py3.10 (diff)
downloadgentoo-2883c689d2f26e974b219a1bc04129541f888770.tar.gz
gentoo-2883c689d2f26e974b219a1bc04129541f888770.tar.bz2
gentoo-2883c689d2f26e974b219a1bc04129541f888770.zip
dev-python/slimit: Enable py3.9 & py3.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/slimit')
-rw-r--r--dev-python/slimit/slimit-0.8.1-r1.ebuild10
1 files changed, 4 insertions, 6 deletions
diff --git a/dev-python/slimit/slimit-0.8.1-r1.ebuild b/dev-python/slimit/slimit-0.8.1-r1.ebuild
index adb879571797..d402ab74e3ea 100644
--- a/dev-python/slimit/slimit-0.8.1-r1.ebuild
+++ b/dev-python/slimit/slimit-0.8.1-r1.ebuild
@@ -1,11 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( pypy3 python3_{7,8} )
+EAPI=7
+PYTHON_COMPAT=( pypy3 python3_{7..10} )
inherit distutils-r1
DESCRIPTION="A JavaScript minifier written in Python"
@@ -34,5 +32,5 @@ python_compile() {
}
python_test() {
- pytest -vv "${BUILD_DIR}" || die "Tests failed with ${EPYTHON}"
+ epytest "${BUILD_DIR}"
}