summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-08-04 04:28:47 +0000
committerSam James <sam@gentoo.org>2020-08-04 04:28:47 +0000
commitabadfcde10dca256041fb9fd8a3ea930f7d1a3ff (patch)
tree2ee5d370028359ed579c0a8be22027e7bf5f5d73 /dev-python/sentry-sdk
parentdev-python/rq: add missing test dep (diff)
downloadgentoo-abadfcde10dca256041fb9fd8a3ea930f7d1a3ff.tar.gz
gentoo-abadfcde10dca256041fb9fd8a3ea930f7d1a3ff.tar.bz2
gentoo-abadfcde10dca256041fb9fd8a3ea930f7d1a3ff.zip
dev-python/sentry-sdk: shift test restriction
The restriction was intended for the earlier version. This version will get cleaned up after a few days, but the tests can't run with the current *_test implementation anyway - they fail because src/ doesn't exist. There are other problems with running tests in the latest version, but we will get there eventually by packaging some dependencies. Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/sentry-sdk')
-rw-r--r--dev-python/sentry-sdk/sentry-sdk-0.14.4.ebuild2
-rw-r--r--dev-python/sentry-sdk/sentry-sdk-0.16.3.ebuild1
2 files changed, 2 insertions, 1 deletions
diff --git a/dev-python/sentry-sdk/sentry-sdk-0.14.4.ebuild b/dev-python/sentry-sdk/sentry-sdk-0.14.4.ebuild
index 6687c9c45aa7..7cf55716208b 100644
--- a/dev-python/sentry-sdk/sentry-sdk-0.14.4.ebuild
+++ b/dev-python/sentry-sdk/sentry-sdk-0.14.4.ebuild
@@ -22,6 +22,8 @@ RDEPEND="
dev-python/certifi
"
+RESTRICT="test"
+
python_test() {
cd "${S}"/src || die
"${PYTHON}" test_typing.py || die "tests failed under ${EPYTHON}"
diff --git a/dev-python/sentry-sdk/sentry-sdk-0.16.3.ebuild b/dev-python/sentry-sdk/sentry-sdk-0.16.3.ebuild
index 37bcbc7c7504..180866d812cb 100644
--- a/dev-python/sentry-sdk/sentry-sdk-0.16.3.ebuild
+++ b/dev-python/sentry-sdk/sentry-sdk-0.16.3.ebuild
@@ -23,4 +23,3 @@ RDEPEND="
# No tests for now
# Need unpackaged: executing, fakeredis
-RESTRICT="test"