summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-31 17:22:54 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-31 17:58:06 +0200
commit10201cf88f6f4ddc0a0b2f2a6e30c3915f077ba8 (patch)
tree381f9857489f7c64ab2594598874458181667c2e /dev-python/sentry-sdk
parentdev-python/aiohttp-socks: Bump to 0.9.0 (diff)
downloadgentoo-10201cf88f6f4ddc0a0b2f2a6e30c3915f077ba8.tar.gz
gentoo-10201cf88f6f4ddc0a0b2f2a6e30c3915f077ba8.tar.bz2
gentoo-10201cf88f6f4ddc0a0b2f2a6e30c3915f077ba8.zip
dev-python/sentry-sdk: Bump to 2.12.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sentry-sdk')
-rw-r--r--dev-python/sentry-sdk/Manifest1
-rw-r--r--dev-python/sentry-sdk/sentry-sdk-2.12.0.ebuild128
2 files changed, 129 insertions, 0 deletions
diff --git a/dev-python/sentry-sdk/Manifest b/dev-python/sentry-sdk/Manifest
index 6286a7a7a475..40503959b560 100644
--- a/dev-python/sentry-sdk/Manifest
+++ b/dev-python/sentry-sdk/Manifest
@@ -1,3 +1,4 @@
DIST sentry-python-1.45.1.gh.tar.gz 474940 BLAKE2B ae3195bceee5beb79d36958b79992fc8433d5315052e7cb4dde2dad4a21482549b28325329a9bd6cc44376acff69ca41b1506e7341c17314318cc93360b5fbcd SHA512 15c42187ef1a9ec1515e23e4e49980e8aecec4bd1f63866bc793bbaf75d9663a636d34c1fcc46faec839685d50366e0a2c9a2e735780d8a1f47f5986bf9fc6a6
DIST sentry-python-2.11.0.gh.tar.gz 537891 BLAKE2B ce46efe95a61088f92c02c13ed55c4cde4e1b17cbfbbbdbb0b8092f83d5571239d004810ca193f7954f0469018b2b881ec254530c13d58056993c2811a14a376 SHA512 339ed1b325c84ef350ca29deb326b4adff5a9b648a03ec28dcf6ca461856c79b2f30944a1360204d54020732564f6c30ebe3fc8902c3b3c2a7e66e5bb0f7994b
+DIST sentry-python-2.12.0.gh.tar.gz 537094 BLAKE2B cb009c4569e5defae8cfb44bbc1260d63554dc0f002675910e8be0b9d0259f89a860d2852d9f9af8460c76d2eb311339f40847d94bc05fb06fbd677cad3d46e3 SHA512 61cdd006792dbcf4cb77f1dd3935d1ba1232361aa2e7b48f2b423873fec88c6d01c24c52cc4520989a501d372ee1d22a580ef89887c454045f6d5ce20e2e2c32
DIST sentry-python-2.9.0.gh.tar.gz 531490 BLAKE2B 8b67caa6911fd44e58c2a1d1206e6ecb9dc31f81c15c66763a04f1a65fc89d4667e60f27e055016342c6b4cac5470729c802ffb046e6e0796d5bfd7044caf27d SHA512 aed112a2ee35e23a1431486ff18e67772476ecfc63eacc388d17454a723b98f6e05cfa95a6c9db2cb6be572eed73d249951a411c60184b20eb251520071a4254
diff --git a/dev-python/sentry-sdk/sentry-sdk-2.12.0.ebuild b/dev-python/sentry-sdk/sentry-sdk-2.12.0.ebuild
new file mode 100644
index 000000000000..12930ca8256b
--- /dev/null
+++ b/dev-python/sentry-sdk/sentry-sdk-2.12.0.ebuild
@@ -0,0 +1,128 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{11..12} )
+
+inherit distutils-r1
+
+MY_P=sentry-python-${PV}
+DESCRIPTION="Python client for Sentry"
+HOMEPAGE="
+ https://sentry.io/
+ https://github.com/getsentry/sentry-python/
+ https://pypi.org/project/sentry-sdk/
+"
+SRC_URI="
+ https://github.com/getsentry/sentry-python/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/asttokens[${PYTHON_USEDEP}]
+ dev-python/executing[${PYTHON_USEDEP}]
+ dev-python/fakeredis[${PYTHON_USEDEP}]
+ dev-python/flask-login[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pyrsistent[${PYTHON_USEDEP}]
+ <dev-python/pytest-8[${PYTHON_USEDEP}]
+ dev-python/pytest-aiohttp[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/python-socks[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/zope-event[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}/sentry-sdk-1.21.0-ignore-warnings.patch"
+)
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # tests require Internet access
+ tests/integrations/httpx/test_httpx.py
+ tests/integrations/requests/test_requests.py
+ tests/integrations/django/test_basic.py
+ tests/integrations/socket/test_socket.py
+ # wtf is it supposed to do?!
+ tests/integrations/gcp/test_gcp.py
+ # TODO
+ tests/integrations/bottle
+ # TODO: most of them hang
+ tests/integrations/starlette
+ # TODO
+ tests/integrations/tornado
+ # requires mockupdb
+ tests/integrations/pymongo
+ # requires AWS access
+ tests/integrations/aws_lambda
+ # requires quart_auth
+ tests/integrations/quart
+ # TODO: require opentelemetry (with py3.10)
+ tests/integrations/opentelemetry
+ # broken (incompatible rq version?)
+ tests/integrations/rq
+ )
+
+ local EPYTEST_DESELECT=(
+ # hangs
+ tests/integrations/threading/test_threading.py::test_propagates_threadpool_hub
+ # broken teardown?
+ tests/test_client.py::test_uwsgi_warnings
+ # too many dependencies installed, sigh
+ tests/test_new_scopes_compat_event.py
+ # Internet
+ tests/integrations/stdlib/test_httplib.py::test_outgoing_trace_headers
+ tests/integrations/stdlib/test_httplib.py::test_outgoing_trace_headers_head_sdk
+ tests/integrations/aiohttp/test_aiohttp.py::test_span_origin
+ tests/integrations/stdlib/test_httplib.py::test_span_origin
+ tests/integrations/stdlib/test_subprocess.py::test_subprocess_span_origin
+ # TODO
+ tests/integrations/aiohttp/test_aiohttp.py::test_basic
+ tests/integrations/django
+ tests/integrations/sqlalchemy/test_sqlalchemy.py::test_orm_queries
+ tests/integrations/sqlalchemy/test_sqlalchemy.py::test_query_source
+ tests/integrations/sqlalchemy/test_sqlalchemy.py::test_transactions
+ tests/integrations/stdlib/test_subprocess.py::test_subprocess_basic
+ tests/integrations/threading/test_threading.py
+ tests/integrations/wsgi/test_wsgi.py
+ tests/test_basics.py::test_auto_enabling_integrations_catches_import_error
+ tests/test_client.py::test_databag_breadth_stripping
+ tests/test_client.py::test_databag_depth_stripping
+ tests/test_client.py::test_databag_string_stripping
+ tests/test_utils.py::test_default_release
+ tests/tracing/test_sampling.py::test_records_lost_event_only_if_traces_sample_rate_enabled
+ tests/tracing/test_sampling.py::test_records_lost_event_only_if_traces_sampler_enabled
+ tests/utils/test_contextvars.py::test_leaks
+ # pointless, fragile to packages being installed in parallel
+ tests/test_utils.py::test_installed_modules
+ # TODO
+ tests/profiler/test_continuous_profiler.py::test_continuous_profiler_auto_start_and_manual_stop
+ tests/profiler/test_continuous_profiler.py::test_continuous_profiler_manual_start_and_stop
+ tests/profiler/test_transaction_profiler.py::test_minimum_unique_samples_required
+ tests/profiler/test_transaction_profiler.py::test_profile_captured
+ tests/profiler/test_transaction_profiler.py::test_profiles_sample_rate
+ tests/profiler/test_transaction_profiler.py::test_profiles_sampler
+ tests/new_scopes_compat/test_new_scopes_compat_event.py
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p asyncio -p aiohttp -p pytest_forked -o addopts=
+}