summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-02-15 00:52:28 +0100
committerManuel Rüger <mrueg@gentoo.org>2017-02-15 00:52:28 +0100
commitece6b2ad9c6e4a0705d0b06dce1143c03f02d6cb (patch)
tree6d6f0d4437946bd9c85f949088b63bf6122ce62f /dev-python/sancho
parentdev-python/python-cdb: Remove old (diff)
downloadgentoo-ece6b2ad9c6e4a0705d0b06dce1143c03f02d6cb.tar.gz
gentoo-ece6b2ad9c6e4a0705d0b06dce1143c03f02d6cb.tar.bz2
gentoo-ece6b2ad9c6e4a0705d0b06dce1143c03f02d6cb.zip
dev-python/sancho: Remove old
Package-Manager: portage-2.3.3
Diffstat (limited to 'dev-python/sancho')
-rw-r--r--dev-python/sancho/sancho-2.4.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/dev-python/sancho/sancho-2.4.ebuild b/dev-python/sancho/sancho-2.4.ebuild
deleted file mode 100644
index 4fb69f347f87..000000000000
--- a/dev-python/sancho/sancho-2.4.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="3"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit distutils
-
-MY_P="Sancho-${PV}"
-
-DESCRIPTION="Sancho is a unit testing framework"
-HOMEPAGE="http://www.mems-exchange.org/software/sancho/"
-SRC_URI="http://www.mems-exchange.org/software/files/${PN}/${MY_P}.tar.gz"
-
-LICENSE="CNRI"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE=""
-
-DEPEND=""
-RDEPEND=""
-
-S="${WORKDIR}/${MY_P}"
-
-DOCS="CHANGES.txt"
-
-src_test() {
- cd test
- testing() {
- local test test_failure test_failure_count=0
- for test in *.py; do
- test_failure="0"
- ebegin "Testing ${test}"
- PYTHONPATH="../build-${PYTHON_ABI}/lib" "$(PYTHON)" "${test}" > "${test}.output"
- grep -Eqv "^${test}: .*:$" "${test}.output" && test_failure="1"
- eend "${test_failure}"
- if [[ "${test_failure}" == "1" ]]; then
- ((test_failure_count++))
- eerror "Failure output for ${test}"
- cat "${test}.output"
- fi
- done
- if [[ "${test_failure_count}" -gt "0" ]]; then
- die "${test_failure_count} tests failed with Python ${PYTHON_ABI}"
- fi
- }
- python_execute_function testing
-}