summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-13 04:37:35 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-13 04:37:35 +0200
commitbf34b2438d7ca5d39b9dbd7272fb391bb6c9b48e (patch)
treee0bf58b219b5d11bcbd79b4326b3f948dd998c26 /dev-python/sabctools
parentdev-python/pytesseract: Bump to 0.3.12 (diff)
downloadgentoo-bf34b2438d7ca5d39b9dbd7272fb391bb6c9b48e.tar.gz
gentoo-bf34b2438d7ca5d39b9dbd7272fb391bb6c9b48e.tar.bz2
gentoo-bf34b2438d7ca5d39b9dbd7272fb391bb6c9b48e.zip
dev-python/sabctools: Bump to 7.1.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sabctools')
-rw-r--r--dev-python/sabctools/Manifest1
-rw-r--r--dev-python/sabctools/sabctools-7.1.2.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/sabctools/Manifest b/dev-python/sabctools/Manifest
index e2bac5d5af7a..50d1e3d33564 100644
--- a/dev-python/sabctools/Manifest
+++ b/dev-python/sabctools/Manifest
@@ -1,3 +1,4 @@
DIST sabctools-7.0.2.gh.tar.gz 8539819 BLAKE2B 38212656c745238f106fbc9334f6dccb02bb9e05153bc73a21a783a25a0c5a63cae2893a01fcceefe37e6f5f187fc6d762fcc632f1228410e951740c808e0e9e SHA512 05968a29afb7a041549bae9e9a4303160820da4cd10ea33ab4475fe48fd0b4cf46023c6254715161265f3e1bdf2b66ae7e62007789fbc288aa229d3a218a3df8
DIST sabctools-7.1.0.gh.tar.gz 8539861 BLAKE2B d19f46dc9d92ebd59f74b74f21129c11d425e690d9b43278cc691c41a2f85bf307775969f6bc0716ac74cd4f630971caa0896ac7c6af129bb9c58383e5afdba3 SHA512 bba1c441111aafd8b028a34637d1f9b855b7d232545bc6e56f7cc650bc22a7ee6a1ad6258aa963ef338a061adb5cd9692e1d6ea215ca7bd9fa7bf06b90079e5b
DIST sabctools-7.1.1.gh.tar.gz 8963314 BLAKE2B 583ac11ba8f4ef9d0f9d04a1697bb7e09644f2edfa851e175bf6454600e2d78bfb593c2fd3696ee077f3243084c90faa276eddd21578122233090be905367d55 SHA512 461f554d4e0032b4a4b0eaa4801d45cd014be00b5cd2f2c13ed7686d20994bb111c80fe8486a50af5622b3977056bd12d2465922f7daccd04a92af7101e52e0f
+DIST sabctools-7.1.2.gh.tar.gz 8963375 BLAKE2B a404780c40cd98a605af58a79c9ecf7c5e479460db925c34486bc36621e749dcad363225e7a73e0222cc30b7bba8747d5d21ed4ac240c5df75485a2bd620e962 SHA512 7887ff3f6b46bd538540b591ab7b47a7b3efa277b45d69ed7329252b1f7326adfa6b286cc207a4262002a802c6acff03c0df4792e099da3dd8be1c3dd68a1ae0
diff --git a/dev-python/sabctools/sabctools-7.1.2.ebuild b/dev-python/sabctools/sabctools-7.1.2.ebuild
new file mode 100644
index 000000000000..a500ef55dcbb
--- /dev/null
+++ b/dev-python/sabctools/sabctools-7.1.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_PN="sabctools"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Module providing raw yEnc encoding/decoding for SABnzbd"
+HOMEPAGE="
+ https://github.com/sabnzbd/sabctools/
+ https://pypi.org/project/sabctools/
+"
+SRC_URI="
+ https://github.com/sabnzbd/${MY_PN}/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/portend[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( README.md doc/yenc-draft.1.3.txt )
+
+distutils_enable_tests pytest