summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-15 09:37:45 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-15 12:05:38 +0100
commitb80124976e1adb02b7f322ccce67619ebed9db32 (patch)
treef8253614e7bacf2d80c9f843b15901a037955701 /dev-python/rq
parentdev-python/attrs: Remove old (diff)
downloadgentoo-b80124976e1adb02b7f322ccce67619ebed9db32.tar.gz
gentoo-b80124976e1adb02b7f322ccce67619ebed9db32.tar.bz2
gentoo-b80124976e1adb02b7f322ccce67619ebed9db32.zip
dev-python/rq: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/rq')
-rw-r--r--dev-python/rq/Manifest1
-rw-r--r--dev-python/rq/rq-1.5.2.ebuild66
2 files changed, 0 insertions, 67 deletions
diff --git a/dev-python/rq/Manifest b/dev-python/rq/Manifest
index 4ddc9fdfd8cd..c6250e6d280c 100644
--- a/dev-python/rq/Manifest
+++ b/dev-python/rq/Manifest
@@ -1,3 +1,2 @@
-DIST rq-1.5.2.tar.gz 570138 BLAKE2B de1f9b9b1d790d0ea3efcd93e916f79b2f28521571652ba048adc725bd53b657cab5a7b2bc65b320a1c2766f77dba399ae62e90fa0a2514fc59565b8949c0327 SHA512 2e2cfe97d427057281415cfb1593ad504485b0398b72f55a93cfa48c7bae8f800ed1b1ad2aa447fe3f6baabd7bb112af29181577d31b270aee58cf4558d15a5b
DIST rq-1.6.1.tar.gz 572668 BLAKE2B 4a1990492ed0c5e999fa918cdf49c03cf664e809b74f75c0aa941a72d9f3f45481e66c0d04780b88efa8e8ac2a8a94b11a0ad620d4c5f99e8abb3582db28e3d3 SHA512 8fc5f0cb87fb43fd6a0981dfb24a21d858e2d9fb2003c955d6d83b33a10b3cbaa713c11e422a91b4e020073d931fd3942530f3368fc8688dcff1a71fbe83fb15
DIST rq-1.7.0.tar.gz 579373 BLAKE2B 835868a294478af07b9fa97fef14b0f2013abe125263efa15c4988eeaf564ee61ab2e8d68842c730a0f8b02a19a4d66f328828fb939a05b9d3b36996688192e0 SHA512 4027a8e1474cc350cf539ecf5734c2f851ef4e61bf0e106e44f359736f4f1ec4e690af97a119d12b1b7614b38ec4da286acff98b718ef604b5c367b3cc2af741
diff --git a/dev-python/rq/rq-1.5.2.ebuild b/dev-python/rq/rq-1.5.2.ebuild
deleted file mode 100644
index ad1ea88ea2c2..000000000000
--- a/dev-python/rq/rq-1.5.2.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8,9} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1
-
-DESCRIPTION="simple, lightweight library for creating and processing background jobs"
-HOMEPAGE="https://python-rq.org https://github.com/rq/rq"
-SRC_URI="https://github.com/rq/rq/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~ppc ~ppc64 x86"
-
-BDEPEND="
- test? (
- dev-db/redis
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/sentry-sdk[${PYTHON_USEDEP}]
- )
-"
-DEPEND="
- >=dev-python/click-5.0[${PYTHON_USEDEP}]
- >=dev-python/redis-py-3.5.0[${PYTHON_USEDEP}]
-"
-RDEPEND="${DEPEND}"
-
-distutils_enable_tests pytest
-
-PATCHES=(
- "${FILESDIR}/${PN}-1.5.0-no-install-tests.patch"
-)
-
-src_test() {
- local redis_pid="${T}"/redis.pid
- local redis_port=6379
- local redis_test_config="daemonize yes
- pidfile ${redis_pid}
- port ${redis_port}
- bind 127.0.0.1
- "
-
- # Spawn Redis itself for testing purposes
- # NOTE: On sam@'s machine, spawning Redis can hang in the sandbox.
- # I'm not restricting tests yet because this doesn't happen for anyone else AFAICT.
- elog "Spawning Redis"
- elog "NOTE: Port ${redis_port} must be free"
- /usr/sbin/redis-server - <<< "${redis_test_config}" || die
-
- # Run the actual tests
- distutils-r1_src_test
-
- # Clean up afterwards
- kill "$(<"${redis_pid}")" || die
-}
-
-python_test() {
- # Tests needing rqworker:
- # TestWorkerSubprocess::test_run_access_self, test_run_empty_queue, test_run_scheduled_access_self
- distutils_install_for_testing
- PATH="${BUILD_DIR}/test/scripts:${PATH}" pytest -vv || die "Testsuite failed under ${EPYTHON}"
-}