summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-23 09:26:25 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-23 09:39:10 +0100
commit446158e3b1ba0b5d0cb084b7161deb11abc3ace1 (patch)
tree5c1bef1ff91799c41b62fdf92a1ccbf799ee8266 /dev-python/rfc3339-validator/rfc3339-validator-0.1.3.ebuild
parentxfce-extra/xfce4-systemload-plugin: Bump to 1.3.1 (diff)
downloadgentoo-446158e3b1ba0b5d0cb084b7161deb11abc3ace1.tar.gz
gentoo-446158e3b1ba0b5d0cb084b7161deb11abc3ace1.tar.bz2
gentoo-446158e3b1ba0b5d0cb084b7161deb11abc3ace1.zip
dev-python/rfc3339-validator: Bump to 0.1.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/rfc3339-validator/rfc3339-validator-0.1.3.ebuild')
-rw-r--r--dev-python/rfc3339-validator/rfc3339-validator-0.1.3.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/rfc3339-validator/rfc3339-validator-0.1.3.ebuild b/dev-python/rfc3339-validator/rfc3339-validator-0.1.3.ebuild
new file mode 100644
index 000000000000..1b50d3cc8562
--- /dev/null
+++ b/dev-python/rfc3339-validator/rfc3339-validator-0.1.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="A pure python RFC3339 validator"
+HOMEPAGE="https://github.com/naimetti/rfc3339-validator"
+SRC_URI="
+ https://github.com/naimetti/rfc3339-validator/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]
+ dev-python/strict-rfc3339[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? ( dev-python/hypothesis[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests pytest