summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-05-29 21:01:36 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-05-29 21:26:42 +0300
commit06aac848c226f77ea37b15cb7a85f4a2e5701fea (patch)
treee11ff3f5bfcc39f949899ed882db2c2590206b5b /dev-python/retrying/retrying-1.3.3-r1.ebuild
parentwww-client/chromium: add missing || die, re-add arm64 fix (diff)
downloadgentoo-06aac848c226f77ea37b15cb7a85f4a2e5701fea.tar.gz
gentoo-06aac848c226f77ea37b15cb7a85f4a2e5701fea.tar.bz2
gentoo-06aac848c226f77ea37b15cb7a85f4a2e5701fea.zip
dev-python/retrying: EAPI=8, USE pep517
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/retrying/retrying-1.3.3-r1.ebuild')
-rw-r--r--dev-python/retrying/retrying-1.3.3-r1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/retrying/retrying-1.3.3-r1.ebuild b/dev-python/retrying/retrying-1.3.3-r1.ebuild
new file mode 100644
index 000000000000..f4d1b369e280
--- /dev/null
+++ b/dev-python/retrying/retrying-1.3.3-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="General-purpose retrying library"
+HOMEPAGE="https://github.com/rholder/retrying"
+SRC_URI="https://github.com/rholder/retrying/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+RDEPEND=">=dev-python/six-1.7.0[${PYTHON_USEDEP}]"
+
+distutils_enable_tests unittest