summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-17 17:19:09 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-17 17:24:40 +0100
commitc3d98121ab09d9c3a4b8e58c61162e5dbec13f4c (patch)
tree6f3281623dc0a36e757a7584e2ae2579f2b0bed4 /dev-python/recurring-ical-events
parentdev-python/jq: Bump to 1.7.0 (diff)
downloadgentoo-c3d98121ab09d9c3a4b8e58c61162e5dbec13f4c.tar.gz
gentoo-c3d98121ab09d9c3a4b8e58c61162e5dbec13f4c.tar.bz2
gentoo-c3d98121ab09d9c3a4b8e58c61162e5dbec13f4c.zip
dev-python/recurring-ical-events: Bump to 2.1.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/recurring-ical-events')
-rw-r--r--dev-python/recurring-ical-events/Manifest1
-rw-r--r--dev-python/recurring-ical-events/recurring-ical-events-2.1.3.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/recurring-ical-events/Manifest b/dev-python/recurring-ical-events/Manifest
index 47fa7b718bc3..329f90307add 100644
--- a/dev-python/recurring-ical-events/Manifest
+++ b/dev-python/recurring-ical-events/Manifest
@@ -1 +1,2 @@
DIST python-recurring-ical-events-2.1.2.gh.tar.gz 328669 BLAKE2B 03bbae75a81526d855860c045711817200c1fca8a97574d324100a7d77c46f687ddb572d516a0bcddf90d629d9d9ff9bf7b2c868db5e6561447a1cd3b6b4f04b SHA512 42c11a211539cf6e40903f9df8224e8dd1dd68fe4894aa0ab1c2660c69a95d4cd1d9f41aa918d5180568f8ca3eecace0d5b845d669d7e532d61a7fa1f5283fd6
+DIST python-recurring-ical-events-2.1.3.gh.tar.gz 329303 BLAKE2B c034fa558629bb8b3c6a901278d14a91826c3dfc805f6960936cd6dc1b219aff027615b05501c85767ab554112f6edf2a2467ced220bd92a7ac493673ca02ffe SHA512 1852b5ed09d1c531ac969aac338893e0409a54d6b0d59e15dbdcbe2a5f97f111c1c01272fa5df640d26c1a12fbc5f284e35c3e10aed0f16a842fe8a6a54462a7
diff --git a/dev-python/recurring-ical-events/recurring-ical-events-2.1.3.ebuild b/dev-python/recurring-ical-events/recurring-ical-events-2.1.3.ebuild
new file mode 100644
index 000000000000..b1d8fa71740b
--- /dev/null
+++ b/dev-python/recurring-ical-events/recurring-ical-events-2.1.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=python-${P}
+DESCRIPTION="Repeat ICalendar events by RRULE, RDATE and EXDATE"
+HOMEPAGE="
+ https://github.com/niccokunzmann/python-recurring-ical-events/
+ https://pypi.org/project/recurring-ical-events/
+"
+SRC_URI="
+ https://github.com/niccokunzmann/python-recurring-ical-events/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ <dev-python/icalendar-6[${PYTHON_USEDEP}]
+ >=dev-python/icalendar-5.0.9[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.1[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2023.3[${PYTHON_USEDEP}]
+ <dev-python/x-wr-timezone-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/x-wr-timezone-0.0.5[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ test/test_readme.py
+)
+
+EPYTEST_DESELECT=(
+ # a test checking if tzdata package is installed that is apparently
+ # needed for other tests, except it isn't
+ test/test_zoneinfo_issue_57.py::test_zoneinfo_must_be_installed_if_it_is_possible
+)