summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-05 09:53:48 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-05 11:41:09 +0200
commit90942eb5ebf32cc76e539b84768ac857d01142f8 (patch)
treeaa57a6575244e7c5204027de6deb1d29584d2e95 /dev-python/rapidfuzz
parentdev-python/rapidfuzz: Remove old (diff)
downloadgentoo-90942eb5ebf32cc76e539b84768ac857d01142f8.tar.gz
gentoo-90942eb5ebf32cc76e539b84768ac857d01142f8.tar.bz2
gentoo-90942eb5ebf32cc76e539b84768ac857d01142f8.zip
dev-python/rapidfuzz: Bump 2.11.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/rapidfuzz')
-rw-r--r--dev-python/rapidfuzz/Manifest1
-rw-r--r--dev-python/rapidfuzz/rapidfuzz-2.11.1.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/rapidfuzz/Manifest b/dev-python/rapidfuzz/Manifest
index 9045ead4738b..f551a4487671 100644
--- a/dev-python/rapidfuzz/Manifest
+++ b/dev-python/rapidfuzz/Manifest
@@ -1 +1,2 @@
DIST rapidfuzz-2.11.0.tar.gz 812669 BLAKE2B e7897b2770202d46cb70323d19a79c6f34c379cf43ab211e2ba4d05ef6f1630d49b3cef70ab52bba1ac0a9cc15cd934e86aab829ec84195a6b583a561efc8cb2 SHA512 df5e77248c2a005ff1e0fbd4b4ef15fbdb88a6738d66823ba9bf8c380943c59fe82ac317dab1e6279b33112d2484563d65c33e972d52ab82b083cd8a8aae7ce0
+DIST rapidfuzz-2.11.1.tar.gz 813221 BLAKE2B 1fab9b564396f820c9bd5c240df95a2e864b0e3efffb4239fa2ad719b92d2997d9519ccf906fe04c61a0fc1daf9ed0df734f95d4cdd19529e46716935182030b SHA512 19f6dbff31f11cc16f031f9bf53f7c60051a84f2f81dfc1c17fc83827a7d8551d708420b4116ab91e56b5d6de652b4d571f4055ebcb208e5dd57e8778050ca29
diff --git a/dev-python/rapidfuzz/rapidfuzz-2.11.1.ebuild b/dev-python/rapidfuzz/rapidfuzz-2.11.1.ebuild
new file mode 100644
index 000000000000..208583661aa3
--- /dev/null
+++ b/dev-python/rapidfuzz/rapidfuzz-2.11.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# custom wrapper over setuptools
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Rapid fuzzy string matching in Python using various string metrics"
+HOMEPAGE="
+ https://github.com/maxbachmann/RapidFuzz/
+ https://pypi.org/project/rapidfuzz/
+"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+# all these are header-only libraries
+DEPEND="
+ >=dev-cpp/taskflow-3.0.0
+ >=dev-cpp/rapidfuzz-cpp-1.8.0
+ dev-python/numpy[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/rapidfuzz_capi[${PYTHON_USEDEP}]
+ >=dev-python/scikit-build-0.13.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export RAPIDFUZZ_BUILD_EXTENSION=1