summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-27 17:43:19 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-27 17:59:46 +0200
commit896998328cf3638a2b8a59485384c3981bd33329 (patch)
treed141f7c59cc81ed79ea9badd07182a5f3bbbfb8c /dev-python/pyzotero
parentdev-python/python-box: Bump to 7.1.1 (diff)
downloadgentoo-896998328cf3638a2b8a59485384c3981bd33329.tar.gz
gentoo-896998328cf3638a2b8a59485384c3981bd33329.tar.bz2
gentoo-896998328cf3638a2b8a59485384c3981bd33329.zip
dev-python/pyzotero: Bump to 1.5.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyzotero')
-rw-r--r--dev-python/pyzotero/Manifest1
-rw-r--r--dev-python/pyzotero/pyzotero-1.5.10.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/pyzotero/Manifest b/dev-python/pyzotero/Manifest
index cfc82e273475..0fbc25a5608c 100644
--- a/dev-python/pyzotero/Manifest
+++ b/dev-python/pyzotero/Manifest
@@ -1 +1,2 @@
+DIST pyzotero-1.5.10.tar.gz 526403 BLAKE2B f62607b14dd558f7d3bb74e9758ae3bc762df178ce92c31253d183609dc0e8c48e67382457a6078139e003076ee8b1cd20959d807fdf9fd8bf1cf2c383bbdf1a SHA512 9fe4c337e597786ada1cfdfbe1bbb42f03356e3a1258760f945f22e17fd3c48a77ad1f92b3854fc36be4ffcbaf9453cd7109f2bd339b2bfe837719fdbc71b129
DIST pyzotero-1.5.9.tar.gz 526093 BLAKE2B bf29b557226363d71d536c41fb168b55b0d63dace5789f8abc92b8342bffb1ddcb4344132a68cc401db0ca0a536f534141690b017bc4dcf4d45299dec308a554 SHA512 be8c2135d3cc1bc5defc27a4eaf5233ced01a7c84cdf89074ce318558728c9356ddcf9e4ede4012b03c1f836dde641fee9366ca954e5d3cf35642638c3e38145
diff --git a/dev-python/pyzotero/pyzotero-1.5.10.ebuild b/dev-python/pyzotero/pyzotero-1.5.10.ebuild
new file mode 100644
index 000000000000..9d9ad538c0fd
--- /dev/null
+++ b/dev-python/pyzotero/pyzotero-1.5.10.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A Python client for the Zotero API"
+HOMEPAGE="
+ https://github.com/urschrei/pyzotero/
+ https://pypi.org/project/pyzotero/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ app-text/zotero-bin
+ dev-python/bibtexparser[${PYTHON_USEDEP}]
+ dev-python/feedparser[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/httpretty[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx doc --no-autodoc
+distutils_enable_tests pytest