summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-01-06 10:15:54 +0100
committerMichał Górny <mgorny@gentoo.org>2018-01-06 14:38:48 +0100
commit020428676f9142728ee1cf494b8778aa05e1ee57 (patch)
tree34a1846307e7694b479dbb58ecacba7cbffd04d9 /dev-python/pyzmq
parentdev-python/pywavelets: Clean old up (diff)
downloadgentoo-020428676f9142728ee1cf494b8778aa05e1ee57.tar.gz
gentoo-020428676f9142728ee1cf494b8778aa05e1ee57.tar.bz2
gentoo-020428676f9142728ee1cf494b8778aa05e1ee57.zip
dev-python/pyzmq: Clean old up
Diffstat (limited to 'dev-python/pyzmq')
-rw-r--r--dev-python/pyzmq/Manifest1
-rw-r--r--dev-python/pyzmq/metadata.xml3
-rw-r--r--dev-python/pyzmq/pyzmq-14.4.1.ebuild60
3 files changed, 0 insertions, 64 deletions
diff --git a/dev-python/pyzmq/Manifest b/dev-python/pyzmq/Manifest
index 9f5d485c88d0..517f91d51668 100644
--- a/dev-python/pyzmq/Manifest
+++ b/dev-python/pyzmq/Manifest
@@ -1,2 +1 @@
-DIST pyzmq-14.4.1.tar.gz 995366 BLAKE2B 4a338639fce04c1c639f98d9c0f458524a6339aa4b4fb406dcdb8c4644ad9019f8f4a2dc59c444c5dbf93a830d354d8771246613dd29c5e65df2b43c7574e6ee SHA512 4b71677e4bfa771177a34dbff59cf6dfd54310a8996689a3d62902aaba35c7cf2ad6b7da806f9e189ad4b89fcefe9cbb3e192788eecd5d2c269e8a980b4d50fa
DIST pyzmq-16.0.2.tar.gz 1026531 BLAKE2B b276fea116d56595ff2aca8a00b2b8918c0170cf1522c4bb457f6bb0d44a13e63de18e4d4f53238a1a5b515986e029ffebdded269f191d62eb36d988b328b402 SHA512 40eaf8ce39db86ab3866890d74b92bd6f20d4ae827828a8772003656d899d10ffcfc222d21f344d9daba390824e6c43b9f34e31beb604ec5ee1ec199165f4b96
diff --git a/dev-python/pyzmq/metadata.xml b/dev-python/pyzmq/metadata.xml
index 23953d2e43de..7b2bf120e320 100644
--- a/dev-python/pyzmq/metadata.xml
+++ b/dev-python/pyzmq/metadata.xml
@@ -5,9 +5,6 @@
<email>python@gentoo.org</email>
<name>Python</name>
</maintainer>
- <use>
- <flag name="green">Enable gevent compatibility with zeromq</flag>
- </use>
<upstream>
<remote-id type="pypi">pyzmq</remote-id>
</upstream>
diff --git a/dev-python/pyzmq/pyzmq-14.4.1.ebuild b/dev-python/pyzmq/pyzmq-14.4.1.ebuild
deleted file mode 100644
index f83f0a659620..000000000000
--- a/dev-python/pyzmq/pyzmq-14.4.1.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1 toolchain-funcs
-
-DESCRIPTION="Lightweight and super-fast messaging library built on top of the ZeroMQ library"
-HOMEPAGE="http://www.zeromq.org/bindings:python https://pypi.python.org/pypi/pyzmq"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-3"
-SLOT="0"
-KEYWORDS="amd64 arm ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc examples green test"
-
-# Ensures installation of gevent for test phase
-REQUIRED_USE="test? ( green )"
-
-PY2_USEDEP=$(python_gen_usedep python2_7)
-RDEPEND=">=net-libs/zeromq-2.1.9:=
- dev-python/py[${PYTHON_USEDEP}]
- dev-python/cffi:=[${PYTHON_USEDEP}]
- green? ( dev-python/gevent[${PY2_USEDEP}] )"
-DEPEND="${RDEPEND}
- test? ( dev-python/nose[${PYTHON_USEDEP}] )
- doc? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/numpydoc[${PYTHON_USEDEP}]
- )"
-
-python_configure_all() {
- tc-export CC
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_compile() {
- python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
- distutils-r1_python_compile
-}
-
-python_test() {
- if python_is_python3; then
- einfo "Skipping python3 due to lack of support by gevent"
- else
- nosetests -svw "${BUILD_DIR}/lib/"
- fi
-}
-
-python_install_all() {
- use examples && local EXAMPLES=( examples/. )
- use doc && local HTML_DOCS=( docs/build/html/. )
- distutils-r1_python_install_all
-}