summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-10-29 06:27:27 +0000
committerSam James <sam@gentoo.org>2023-10-29 06:50:26 +0000
commita94d9ab3c28fa4ac98993b5e4c44149f03705873 (patch)
tree1056d758a7470b0166f32267500d3d5f90cc1bf0 /dev-python/pythran
parentRevert "sys-apps/systemd: Stabilize 254.5 hppa, #916072" (diff)
downloadgentoo-a94d9ab3c28fa4ac98993b5e4c44149f03705873.tar.gz
gentoo-a94d9ab3c28fa4ac98993b5e4c44149f03705873.tar.bz2
gentoo-a94d9ab3c28fa4ac98993b5e4c44149f03705873.zip
dev-python/pythran: fix test linkage with blas
Closes: https://bugs.gentoo.org/916461 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/pythran')
-rw-r--r--dev-python/pythran/pythran-0.14.0.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/dev-python/pythran/pythran-0.14.0.ebuild b/dev-python/pythran/pythran-0.14.0.ebuild
index b15f2a17d6e0..8ae4f640ebee 100644
--- a/dev-python/pythran/pythran-0.14.0.ebuild
+++ b/dev-python/pythran/pythran-0.14.0.ebuild
@@ -52,11 +52,18 @@ BDEPEND="
distutils_enable_tests pytest
src_configure() {
- cat >> setup.cfg <<-EOF
+ cat >> setup.cfg <<-EOF || die
[build_py]
no_boost = True
no_xsimd = True
EOF
+
+ if use test ; then
+ sed -i \
+ -e 's|blas=blas|blas=cblas|' \
+ -e 's|libs=|libs=cblas|' \
+ pythran/pythran-*.cfg || die
+ fi
}
python_test() {