summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-06 04:44:58 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-06 05:07:44 +0200
commit0ea25b517793fb82d41f19412ddbbba1952efb83 (patch)
tree83fb87fea4e3f497d14f93a170a2153e107893af /dev-python/python-swiftclient
parentdev-python/plotly: Bump to 5.14.1 (diff)
downloadgentoo-0ea25b517793fb82d41f19412ddbbba1952efb83.tar.gz
gentoo-0ea25b517793fb82d41f19412ddbbba1952efb83.tar.bz2
gentoo-0ea25b517793fb82d41f19412ddbbba1952efb83.zip
dev-python/python-swiftclient: Bump to 4.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-swiftclient')
-rw-r--r--dev-python/python-swiftclient/Manifest1
-rw-r--r--dev-python/python-swiftclient/python-swiftclient-4.3.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/python-swiftclient/Manifest b/dev-python/python-swiftclient/Manifest
index 364789090756..bc919e18cfb9 100644
--- a/dev-python/python-swiftclient/Manifest
+++ b/dev-python/python-swiftclient/Manifest
@@ -1 +1,2 @@
DIST python-swiftclient-4.2.0.tar.gz 203334 BLAKE2B 5c64c785b8d3db45c5d89d3c09f27d0caa7a7f7a57afd935c2f10b050882734e966eb5b027bc956b450a19e6aa5d6ed2ad955db556b83a1086ac358d1c82025c SHA512 8426f39a5d37281816570c13491da1f459fe03182a8041fbd362733376d0c7edda6b51e4d3bbcb5ceed79ec7746e127760d1f936326b50a1cc7de102590f45d7
+DIST python-swiftclient-4.3.0.tar.gz 206510 BLAKE2B 6a3683ffbe09905d310dabac5d1d3926125d85b8383e487d916df00e91621bc1bc901ed2ceed23a9ef4ecaf81e86f2560f77f20751a2b8c3ca543114ea5fa3d8 SHA512 8c113122b1dec2eb901b7256b0b5c9e6e3e11959ebdda28f512dd84b0370dcf8e7299594f50649c147526b4076baabf2a0fe6f6f433193d4c198890265f57807
diff --git a/dev-python/python-swiftclient/python-swiftclient-4.3.0.ebuild b/dev-python/python-swiftclient/python-swiftclient-4.3.0.ebuild
new file mode 100644
index 000000000000..edccb0e1001c
--- /dev/null
+++ b/dev-python/python-swiftclient/python-swiftclient-4.3.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python bindings to the OpenStack Object Storage API"
+HOMEPAGE="
+ https://opendev.org/openstack/python-swiftclient/
+ https://github.com/openstack/python-swiftclient/
+ https://pypi.org/project/python-swiftclient/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/requests-2.4.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/keystoneauth1-3.4.0[${PYTHON_USEDEP}]
+ dev-python/python-keystoneclient[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/openstacksdk-0.11.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+python_prepare_all() {
+ sed -e 's/test_password_prompt/_&/' -i test/unit/test_shell.py || die
+ # fix duplicate script/entry point
+ # https://bugs.launchpad.net/python-swiftclient/+bug/1975361
+ sed -i -e '/bin\/swift/d' setup.cfg || die
+ distutils-r1_python_prepare_all
+}