summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-24 10:27:52 +0100
committerMichał Górny <mgorny@gentoo.org>2022-03-24 10:28:16 +0100
commitd6e2fe94878dd87333b87dd273ce726103d3a8fa (patch)
tree257afa771b9587e0ea7b08f0dcd178788e20c388 /dev-python/python-nbxmpp
parentdev-lang/python: Bump to 3.9.12 (diff)
downloadgentoo-d6e2fe94878dd87333b87dd273ce726103d3a8fa.tar.gz
gentoo-d6e2fe94878dd87333b87dd273ce726103d3a8fa.tar.bz2
gentoo-d6e2fe94878dd87333b87dd273ce726103d3a8fa.zip
dev-python/python-nbxmpp: Bump to 2.0.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-nbxmpp')
-rw-r--r--dev-python/python-nbxmpp/Manifest1
-rw-r--r--dev-python/python-nbxmpp/python-nbxmpp-2.0.6.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/python-nbxmpp/Manifest b/dev-python/python-nbxmpp/Manifest
index 0bb603aae5c6..679205cef01e 100644
--- a/dev-python/python-nbxmpp/Manifest
+++ b/dev-python/python-nbxmpp/Manifest
@@ -1,2 +1,3 @@
DIST python-nbxmpp-nbxmpp-2.0.3.tar.bz2 122433 BLAKE2B 9543a93c2ea372fbe8412c410252907eeaa00e2576bbe4a614141d521d03ef997481b482e9990376cd5b8139e5daa01e51f946fd9792fb26bc0084e04f3b1de0 SHA512 6ba1dc045a7f6d761e8d9d5da9f4799aaff96155fa7260c76820bbe9c11d95a11777fe73b9f405ee9e4b93be2167dd575fae4cb880f0690bb6a99d091a5eadfc
DIST python-nbxmpp-nbxmpp-2.0.4.tar.bz2 122568 BLAKE2B 3ca2213018ee561e9778ca6107e3a55ef6635a1f859d7cec6f08ac7ac6b3e3a7b4dd2dc38e3305fdcfca94b2003aef5525efc2f992b25fe5d5e44090c199fad4 SHA512 52e819019abaec8fb3fdf7c64bc7bf29d94d77d8b3c550fd8c05223eef81e50d8a992fb12b56198f389860f1bd55f915b781ae5a1d66b40bcbe17fec3fa0d540
+DIST python-nbxmpp-nbxmpp-2.0.6.tar.bz2 122203 BLAKE2B 925604002f4363f1e0b72f05c13742f4652ba565a9faa48faf8d47688f480a7f1d7585c593b0dcf07bded8c4aa3a1d02e9697742a07b9e815daec062dfb93104 SHA512 a536b25c8a6298892a51adef4b64b75ffab88ce02fb08fc07ecd1cfe2bc794262d4d58a93248439723e6e0544485da7351bb98189b0e422a1f77b01c6f6d238e
diff --git a/dev-python/python-nbxmpp/python-nbxmpp-2.0.6.ebuild b/dev-python/python-nbxmpp/python-nbxmpp-2.0.6.ebuild
new file mode 100644
index 000000000000..9130ac17363c
--- /dev/null
+++ b/dev-python/python-nbxmpp/python-nbxmpp-2.0.6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+MY_P=python-nbxmpp-nbxmpp-${PV}
+DESCRIPTION="Python library to use Jabber/XMPP networks in a non-blocking way"
+HOMEPAGE="https://dev.gajim.org/gajim/python-nbxmpp/"
+SRC_URI="
+ https://dev.gajim.org/gajim/python-nbxmpp/-/archive/nbxmpp-${PV}/${MY_P}.tar.bz2
+"
+S=${WORKDIR}/${MY_P}
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-libs/gobject-introspection
+ net-libs/libsoup[introspection]
+ dev-python/idna[${PYTHON_USEDEP}]
+ dev-python/precis-i18n[${PYTHON_USEDEP}]
+ dev-python/pygobject[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest