summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-09-25 09:36:34 +0200
committerJustin Lecher <jlec@gentoo.org>2015-09-25 09:36:34 +0200
commitaee01c1b66d4f25b92f5592ba4c91cf20da39a31 (patch)
tree11c933200c09d7f5126af2d523d0a51bd2d40340 /dev-python/python-gnupg/python-gnupg-0.3.8.ebuild
parentdev-python/decorator: Version Bump (diff)
downloadgentoo-aee01c1b66d4f25b92f5592ba4c91cf20da39a31.tar.gz
gentoo-aee01c1b66d4f25b92f5592ba4c91cf20da39a31.tar.bz2
gentoo-aee01c1b66d4f25b92f5592ba4c91cf20da39a31.zip
dev-python/python-gnupg: Version Bump
Package-Manager: portage-2.2.21 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/python-gnupg/python-gnupg-0.3.8.ebuild')
-rw-r--r--dev-python/python-gnupg/python-gnupg-0.3.8.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/python-gnupg/python-gnupg-0.3.8.ebuild b/dev-python/python-gnupg/python-gnupg-0.3.8.ebuild
new file mode 100644
index 000000000000..74e1a0bef119
--- /dev/null
+++ b/dev-python/python-gnupg/python-gnupg-0.3.8.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper for GNU Privacy Guard"
+HOMEPAGE="http://pythonhosted.org/python-gnupg/ https://github.com/vsajip/python-gnupg/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="app-crypt/gnupg"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.3.6-skip-search-keys-tests.patch )
+
+python_test() {
+ # Note; 1 test fails under pypy only
+ "${PYTHON}" test_gnupg.py || die "Tests fail with ${EPYTHON}"
+}