summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-06-16 13:33:00 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-06-16 13:39:01 -0500
commit1301204e27d9c275bf915227b0a4aebddfacf288 (patch)
tree35beb0aa1a05098a9aa1f66ac1b1c3c4364a4b96 /dev-python/python-glanceclient
parentdev-python/python-novaclient: 15.1.1 bump (diff)
downloadgentoo-1301204e27d9c275bf915227b0a4aebddfacf288.tar.gz
gentoo-1301204e27d9c275bf915227b0a4aebddfacf288.tar.bz2
gentoo-1301204e27d9c275bf915227b0a4aebddfacf288.zip
dev-python/python-glanceclient: 2.17.1 bump
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/python-glanceclient')
-rw-r--r--dev-python/python-glanceclient/Manifest1
-rw-r--r--dev-python/python-glanceclient/python-glanceclient-2.17.1.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/python-glanceclient/Manifest b/dev-python/python-glanceclient/Manifest
index 9e7468a4d92b..e5135717d46f 100644
--- a/dev-python/python-glanceclient/Manifest
+++ b/dev-python/python-glanceclient/Manifest
@@ -1 +1,2 @@
DIST python-glanceclient-2.16.0.tar.gz 189395 BLAKE2B 9de8b162c1eb5bfb44700f41cbdcd4f8a983d8c7bd7b281df09db67df6a0de5dee905330f03c967be9e1c3b2aaa379e4c8594f7f4cdbb34870a1e87cb7ccaf1f SHA512 b853f529752247873d9f319d4ec6f4cabc89ee4c26a0c1013e7609fc38e3c9f68d774b3682166e8155e21572a0a011eb6859a84c253ca9f7a9b8b1ccf79b5322
+DIST python-glanceclient-2.17.1.tar.gz 189763 BLAKE2B ef085f6e6e0b8d3c79ab3cce95fdef2066a999258e511fe3c5efa9be577990d8381f07929ead4e83d1859f345ea55629ab75f980d04107e41fec192a64c6f055 SHA512 2082112ce01292b232f63a0a8a95d16f209f33db5c9b81ddc912cef2ce378d5f0bc7ea0e039c0608ab382f3e9f6efe020d71e94b5475391c4d41fc1fca45678e
diff --git a/dev-python/python-glanceclient/python-glanceclient-2.17.1.ebuild b/dev-python/python-glanceclient/python-glanceclient-2.17.1.ebuild
new file mode 100644
index 000000000000..e04d9c12203a
--- /dev/null
+++ b/dev-python/python-glanceclient/python-glanceclient-2.17.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="A client for the OpenStack Glance API"
+HOMEPAGE="https://github.com/openstack/python-glanceclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
+ <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
+ >=dev-python/keystoneauth-3.6.2[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/warlock-1.2.0[${PYTHON_USEDEP}]
+ <dev-python/warlock-2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/wrapt-1.7.0[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-17.1.0[${PYTHON_USEDEP}]
+"