summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2018-08-18 03:33:34 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-08-23 10:17:11 +0200
commitc5334ef14ebf02aa46cda5974db7a41d15f9ccce (patch)
tree7fd8891f951d5f660d8aee10768802bfbf6cd5ed /dev-python/python-fastimport
parentx11-wm/enlightenment: stricter dependency on efl with 'wayland' USE. (diff)
downloadgentoo-c5334ef14ebf02aa46cda5974db7a41d15f9ccce.tar.gz
gentoo-c5334ef14ebf02aa46cda5974db7a41d15f9ccce.tar.bz2
gentoo-c5334ef14ebf02aa46cda5974db7a41d15f9ccce.zip
dev-python/python-fastimport: bump to 0.9.8, add PyPy3, Python 3.7.
Also make tests verbose, use EPYTHON and EAPI=7. Package-Manager: Portage-2.3.45, Repoman-2.3.10 Closes: https://github.com/gentoo/gentoo/pull/9608
Diffstat (limited to 'dev-python/python-fastimport')
-rw-r--r--dev-python/python-fastimport/Manifest1
-rw-r--r--dev-python/python-fastimport/python-fastimport-0.9.8.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/python-fastimport/Manifest b/dev-python/python-fastimport/Manifest
index fef1b1f5e5be..00372e23b44b 100644
--- a/dev-python/python-fastimport/Manifest
+++ b/dev-python/python-fastimport/Manifest
@@ -1,2 +1,3 @@
DIST fastimport-0.9.6.tar.gz 33333 BLAKE2B 46e654c26bd388a61ae0717b66294dbc1261aca9a2b6e1823e6d8afad014fd21d0ea54e70e018ba79cc45dc6111ccf84a4eb68e053c0812773a4c25cb32e0569 SHA512 cc38c1218d65ef4a9e3a68d8af3fadf98c7cc0dcd8075b338b8f492d25765bc2fe2247000868fd3c95e1f7f4c2b9a05964ef7b4f9196c2777f6a7941f127f416
+DIST fastimport-0.9.8.tar.gz 39512 BLAKE2B 484ba865e749cca33df73417285e51a9117e7c905ab2922588d6eef9a64ea6b3d72de285a2affbe7d4a770ead9ece30f6242777087af1c469d59c8f2a4e1b008 SHA512 5d195b641cf6138fdbc6c75781a4a6d3699e3ada9743bbe4c4264879b2da2f8a2e995e7cc3955a5241e9c7a7f24f8114474a0a30907f86e2e335e2be4669f588
DIST python-fastimport-0.9.2.tar.gz 30762 BLAKE2B 2484e02077017c5534afafcc17627bef8875379bd8e66b5610408b5b11feb6db32cd9e97905a9ff3bc23cc58f6e01255bb3e18ea6fa66e0d077a42504e0def39 SHA512 8fd9f89267ca88edff94cea7537740431d02680a1eebd085ee376954b47bf5222e7575750895d0d2da246694cdac7a5afe50d857b87c0f36e04eb3511bcbe472
diff --git a/dev-python/python-fastimport/python-fastimport-0.9.8.ebuild b/dev-python/python-fastimport/python-fastimport-0.9.8.ebuild
new file mode 100644
index 000000000000..159028df4161
--- /dev/null
+++ b/dev-python/python-fastimport/python-fastimport-0.9.8.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{4,5,6,7}} )
+
+inherit distutils-r1
+
+MY_PN="${PN#python-}"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="Library for parsing the fastimport VCS serialization format"
+HOMEPAGE="https://github.com/jelmer/python-fastimport"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}"
+
+python_test() {
+ "${EPYTHON}" -m unittest -v fastimport.tests.test_suite \
+ || die "Tests fail with ${EPYTHON}"
+}