summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/python-djvulibre
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/python-djvulibre')
-rw-r--r--dev-python/python-djvulibre/Manifest1
-rw-r--r--dev-python/python-djvulibre/metadata.xml11
-rw-r--r--dev-python/python-djvulibre/python-djvulibre-0.3.9.ebuild23
3 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/python-djvulibre/Manifest b/dev-python/python-djvulibre/Manifest
new file mode 100644
index 000000000000..6ad85fb91c3f
--- /dev/null
+++ b/dev-python/python-djvulibre/Manifest
@@ -0,0 +1 @@
+DIST python-djvulibre-0.3.9.tar.gz 120663 SHA256 ca11e57ae14161788ba8ee48063136f3fa12aad887035a36c3b2bfb8346c1a44 SHA512 30c3ce2dc09d3e2d1d1c3608a76a4b4ea61d05dbc69a41476cfc3b0e99d68626b4dfbbad0acfdb074fe6ee6c36ad4a4e382a545d3dafc2f12d149fa96e034595 WHIRLPOOL ca675f63bd5455e40e2cac820dcb172043a0dc317830cb8264a4d4ebb6d2f8afa1309e7ab37197d4f9067c8335c3e41e14bed10f33fb11c54cbb0ad0d8a94c03
diff --git a/dev-python/python-djvulibre/metadata.xml b/dev-python/python-djvulibre/metadata.xml
new file mode 100644
index 000000000000..57ee6ea686e3
--- /dev/null
+++ b/dev-python/python-djvulibre/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>pinkbyte@gentoo.org</email>
+ <name>Sergey Popov</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">python-djvulibre</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-djvulibre/python-djvulibre-0.3.9.ebuild b/dev-python/python-djvulibre/python-djvulibre-0.3.9.ebuild
new file mode 100644
index 000000000000..1f9c9486b31f
--- /dev/null
+++ b/dev-python/python-djvulibre/python-djvulibre-0.3.9.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Set of Python bindings for the DjVuLibre library"
+HOMEPAGE="http://jwilk.net/software/python-djvulibre"
+SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="app-text/djvu"
+DEPEND="${RDEPEND}
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"