summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-21 06:15:26 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-21 06:15:26 +0200
commit80c8b50fe6bd2d8af9bf14628b56bd01fba5ef4f (patch)
tree5c4be689c0b49897551d0d4bab2c3786c07e0b04 /dev-python/python-dbusmock
parentdev-python/python-dbusmock: Switch to pypi (not-really-)sdist (diff)
downloadgentoo-80c8b50fe6bd2d8af9bf14628b56bd01fba5ef4f.tar.gz
gentoo-80c8b50fe6bd2d8af9bf14628b56bd01fba5ef4f.tar.bz2
gentoo-80c8b50fe6bd2d8af9bf14628b56bd01fba5ef4f.zip
dev-python/python-dbusmock: Bump to 0.29.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-dbusmock')
-rw-r--r--dev-python/python-dbusmock/Manifest2
-rw-r--r--dev-python/python-dbusmock/python-dbusmock-0.29.0.ebuild40
2 files changed, 41 insertions, 1 deletions
diff --git a/dev-python/python-dbusmock/Manifest b/dev-python/python-dbusmock/Manifest
index 492466541ad0..a0bee08f8030 100644
--- a/dev-python/python-dbusmock/Manifest
+++ b/dev-python/python-dbusmock/Manifest
@@ -1,2 +1,2 @@
-DIST python-dbusmock-0.28.7.gh.tar.gz 91302 BLAKE2B edad30e569652b2fc8e2f7437e818eece2b88be460ca31eab0be6a6951f0690a295fa1af3f7a490794bcc454e021cea3e153b300ce55883a9cf8010aac8212a4 SHA512 d0fea9ad3a9f76af75f48a4e645f8ed70efde880043c9b843bc8cac53eca891c45fa9c74cefab63a820397886757ac0dc9c5f43aaf7604aa302c794aedb7bb46
DIST python-dbusmock-0.28.7.tar.gz 91302 BLAKE2B edad30e569652b2fc8e2f7437e818eece2b88be460ca31eab0be6a6951f0690a295fa1af3f7a490794bcc454e021cea3e153b300ce55883a9cf8010aac8212a4 SHA512 d0fea9ad3a9f76af75f48a4e645f8ed70efde880043c9b843bc8cac53eca891c45fa9c74cefab63a820397886757ac0dc9c5f43aaf7604aa302c794aedb7bb46
+DIST python-dbusmock-0.29.0.tar.gz 92406 BLAKE2B e23a7e81584a94532258237e75f35d1c7fe2cba901d30e1a211d61ce48db2992f1c19d08401059b60b80a3aa7bf6c1e21d096bd30eacb27d16c3189b1f9b7938 SHA512 618f6069802cdfcab41e09c9ed27f2c55c35f072bea4c0b38c057297ff3de0759b1b37128fee8d331d058f3c2a4607f25f0d8b42077f5b4fc155c6e5a4cb94c3
diff --git a/dev-python/python-dbusmock/python-dbusmock-0.29.0.ebuild b/dev-python/python-dbusmock/python-dbusmock-0.29.0.ebuild
new file mode 100644
index 000000000000..c2e2fe6153af
--- /dev/null
+++ b/dev-python/python-dbusmock/python-dbusmock-0.29.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Easily create mock objects on D-Bus for software testing"
+HOMEPAGE="
+ https://github.com/martinpitt/python-dbusmock/
+ https://pypi.org/project/python-dbusmock/
+"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # linter tests, fragile to newer linter versions
+ tests/test_code.py
+)
+
+src_prepare() {
+ # dev-python/dbus-python uses autotools, so no .dist-info there
+ sed -i '/dbus-python/d' pyproject.toml setup.cfg || die
+
+ distutils-r1_src_prepare
+}