summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEttore Di Giacinto <mudler@gentoo.org>2018-01-27 18:09:50 +0100
committerEttore Di Giacinto <mudler@gentoo.org>2018-02-11 16:00:26 +0100
commit20185284055e3ac97290b55b896f9abee022f461 (patch)
treea2edd0b2bd45a6212ac8cd504789b9e65809061d /dev-python/python-caja/python-caja-1.18.1.ebuild
parentapp-editors/pluma: Bump to version 1.18.3 (diff)
downloadgentoo-20185284055e3ac97290b55b896f9abee022f461.tar.gz
gentoo-20185284055e3ac97290b55b896f9abee022f461.tar.bz2
gentoo-20185284055e3ac97290b55b896f9abee022f461.zip
dev-python/python-caja: Bump to version 1.18.1
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-python/python-caja/python-caja-1.18.1.ebuild')
-rw-r--r--dev-python/python-caja/python-caja-1.18.1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/python-caja/python-caja-1.18.1.ebuild b/dev-python/python-caja/python-caja-1.18.1.ebuild
new file mode 100644
index 000000000000..3926c9e7e81f
--- /dev/null
+++ b/dev-python/python-caja/python-caja-1.18.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MATE_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_7 )
+
+inherit mate python-single-r1
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+DESCRIPTION="Python bindings for the Caja file manager"
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="doc"
+
+COMMON_DEPEND="${PYTHON_DEPS}
+ dev-libs/glib:2
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ >=mate-base/caja-1.17.1[introspection]
+ x11-libs/gtk+:3"
+
+RDEPEND="${COMMON_DEPEND}"
+
+DEPEND="${COMMON_DEPEND}
+ dev-util/gtk-doc
+ dev-util/gtk-doc-am
+ virtual/pkgconfig:*
+ doc? ( app-text/docbook-xml-dtd:4.1.2 )"
+
+src_install() {
+ mate_src_install
+
+ # Keep the directory for systemwide extensions.
+ keepdir /usr/share/python-caja/extensions/
+
+ # The HTML documentation generation is broken and commented out by upstream.
+ #
+ #if use doc ; then
+ # insinto /usr/share/gtk-doc/html/nautilus-python # for dev-util/devhelp
+ # doins -r docs/html/*
+ #fi
+}