summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-06 11:24:16 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-06 12:03:23 +0200
commitd5919af9e17798efe3bb50a1088bf672972e41a7 (patch)
treeff1a8c9a7a740b8b44b44e872573470066135a5b /dev-python/python-box
parentdev-util/maturin: add 1.2.0 (diff)
downloadgentoo-d5919af9e17798efe3bb50a1088bf672972e41a7.tar.gz
gentoo-d5919af9e17798efe3bb50a1088bf672972e41a7.tar.bz2
gentoo-d5919af9e17798efe3bb50a1088bf672972e41a7.zip
dev-python/python-box: Fix testing the C extension
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-box')
-rw-r--r--dev-python/python-box/python-box-7.0.1.ebuild14
1 files changed, 13 insertions, 1 deletions
diff --git a/dev-python/python-box/python-box-7.0.1.ebuild b/dev-python/python-box/python-box-7.0.1.ebuild
index de2d866f1d92..c300e79fa62f 100644
--- a/dev-python/python-box/python-box-7.0.1.ebuild
+++ b/dev-python/python-box/python-box-7.0.1.ebuild
@@ -5,7 +5,7 @@ EAPI=8
DISTUTILS_EXT=1
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
inherit distutils-r1
@@ -38,3 +38,15 @@ BDEPEND="
"
distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # looks like broken tests
+ # https://github.com/cdgriffith/Box/issues/257
+ test/test_box.py::TestBox::test_box_kwargs_should_not_be_included
+ test/test_box.py::TestBox::test_box_namespace
+ )
+
+ rm -rf box || die
+ epytest
+}